Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-15984

Inconsistent schema when upgrading

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.8.5, 1.9.3
    • Fix Version/s: None
    • Component/s: Database SQL/XMLDB, Groups
    • Labels:
      None
    • Environment:
      PostgreSQL 8.1.11
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      When upgrading from 1.8.5+ (Build: 20080507) to 1.9.2+ (Build: 20080725), the following schema inconsistencies occur:

      1.) groupings_groups.groupid does not have a default set, though lib/db/install.xml has default="0"
      2.) groups.courseid has default of 0, though lib/db/install.xml has no default
      3.) groups.enrolmentkey has a default of '', though lib/db/install.xml has no default
      4.) groups.name is varchar(255), though lib/db/install.xml is varchar(254)

        Gliffy Diagrams

          Attachments

            Activity

            Hide
            cbandy Chris Bandy added a comment -

            Exactly the same in 1.9.3+ (Build: 20081020)

            Show
            cbandy Chris Bandy added a comment - Exactly the same in 1.9.3+ (Build: 20081020)
            Hide
            salvetore Michael de Raadt added a comment -

            Thanks for reporting this issue.

            We have detected that this issue has been inactive for over a year has been recorded as affecting versions that are no longer supported.

            If you believe that this issue is still relevant to current versions (2.1 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

            Michael d;

            lqjjLKA0p6

            Show
            salvetore Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year has been recorded as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.1 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d; lqjjLKA0p6
            Hide
            salvetore Michael de Raadt added a comment -

            I'm closing this issue as it appears to have become inactive and is probably not relevant to a current supported version. If you are encountering this problem or one similar, please launch a new issue.

            Show
            salvetore Michael de Raadt added a comment - I'm closing this issue as it appears to have become inactive and is probably not relevant to a current supported version. If you are encountering this problem or one similar, please launch a new issue.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: