Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-16168

Moodle CAS crashes if no LDAP is set up

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 1.9.2, 2.0, 2.1, 2.2
    • 1.9.13, 2.0.4, 2.1.2
    • Authentication
    • None
    • This was discovered using Moodle on an Ubuntu server, though I doubt the issue is related to the environment.

    Description

      After configuring CAS on a fresh Moodle install and updating the mdl_user table with:

      update mdl_user set auth='cas';

      we get successfully redirected on login to the CAS server and back to Moodle as we would expect.

      However, it then returns an error about not being able to connect to the LDAP server. We aren't using LDAP, and we didn't configure Moodle to use LDAP, so that would be a bug.

      The patch that we made to work around the bug was to comment out the calls to update_user_record and create_user_record that are found in lib/moodlelib.php. It would be better if Moodle recognized that we were not using LDAP and that it wouldn't try to update or create users in that case.

      Attachments

        Issue Links

          Activity

            People

              iarenaza Iñaki Arenaza
              aelkner Alan Elkner
              Eloy Lafuente (stronk7) Eloy Lafuente (stronk7)
              Nobody Nobody
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski
              Votes:
              20 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                1/Aug/11