Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-16185

Scorm API not always found when SCO is first launched

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.9.1, 1.9.2
    • Fix Version/s: 1.9.4
    • Component/s: SCORM
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      When launching a SCORM course, it can not always find the API causing lost data and errors. Recommend putting a test for the API existing prior to launching the SCORM course.

        Attachments

        1. firebug_api_404.png
          firebug_api_404.png
          85 kB
        2. hello there.zip
          575 kB
        3. PHP Version 5.htm
          283 kB
        4. SCORM_error.mov
          1.09 MB
        5. SCORM_error2.mov
          9.20 MB
        6. scormerror.html
          6 kB
        7. SCORMFunctions.js
          55 kB

          Issue Links

            Activity

              People

              Assignee:
              danmarsden Dan Marsden
              Reporter:
              rmeske Ron Meske
              Participants:
              Component watchers:
              Damyon Wiese, Dan Marsden, Matteo Scaramuccia, Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              3 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                28/Jan/09