Moodle
  1. Moodle
  2. MDL-16274

Navigating SCORM content is slow and unpleasant because the SCORM player reloads for each content page.

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.9.1, 1.9.2
    • Fix Version/s: None
    • Component/s: Performance, SCORM
    • Labels:
      None
    • Environment:
      Any
    • Database:
      Any
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      12660

      Description

      The complete Moodle SCORM player reloads each time when using it's content-tree-menu to navigate to another content page from a SCORM package. Loading the player takes mostly much longer than the actual content page. Like this, navigation through the content of SCORM packages is slow and feels unpleasant.

      Possible solution: When the client uses the content-tree-menu to navigate to another SCORM content page, just load the content page in the existing iFrame without reloading the complete SCORM player. VDAB ( http://vdab.be ) is working on this solution.

      1. 20080910_fastFileParser.php
        1 kB
        Gerd Goetschalckx
      2. 20080910_loadSCO.patch
        1 kB
        Gerd Goetschalckx
      1. MDL_16274.jpeg
        169 kB

        Issue Links

          Activity

          Dan Marsden added a comment -

          Hi Gerd,

          you can attach files to this issue using the "attach file" link on the left hand side. - Feel free to attach a patch file for us to review.

          for information on how to create a patch see here:
          http://docs.moodle.org/en/Development:How_to_create_a_patch

          thanks,

          Dan

          Gerd Goetschalckx added a comment -

          See diagram for concept of solution...

          Gerd Goetschalckx added a comment -

          In the diagram you can see the concept for a solution as we have in mind. This goos further than a patch for player.php in the SCORM module. We think that a new version of player.php can improve the performance of the SCORM player significantly. We would realy appreciate:

          • your feedback on the concept.
          • your feedback on the code.

          Could you suggest how we can enter the code in the community for review? Is there a branch that we can use?

          Dan Marsden added a comment -

          HI Gerd, we cannot provide any feedback on the code as you have not provided any. - The best way to allow review is by adding a patch to this tracker issue for review. As to the "concept" - it "seems" like an ok idea, however I suspect it will cause problems for objects that display the TOC. However we are happy to review any code that you attach.

          Gerd Goetschalckx added a comment -

          Dan,
          Following your questions, you will find:

          • Fastfileparser.php
          • loadsco.php to initiate the Fastfileparser.php

          We have put one of our oldest and simplest packages on an ftp server. I will send you the details by email, because this content is not for public use.

          Dan Marsden added a comment -

          closing this as a duplicate of MDL-16271 - all the more recent information is there anyway. - thanks.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: