Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-16318

use_html_editor was deprecated by there are still about 35 calls to it in core code.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Reassigning to moodle.com, since Mathieu left HQ ages ago.

      Currently, use_html_editor finds just 16 matches in master. That includes 2 mentions in deprecatedlib.php. It also finds matches for can_use_html_editor which is at the end of editorlib.php, with a comment saying 'deprecate this in 2.1'.

      So, it looks like we are in striking distance of getting this cleaned up, if only someone could be bothered.

      I'm adding Michael as a watcher, so that he can triage this.

        Attachments

          Activity

            People

            • Assignee:
              timhunt Tim Hunt
              Reporter:
              timhunt Tim Hunt
              Participants:
              Component watchers:
              Andrew Nicols, Mathew May, Michael Hawkins, Shamim Rezaie, Simey Lameze
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: