Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-16336

HTMLAREA HTML editor doesn't appear in Google Chrome

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.6.7, 1.7.5, 1.8.6, 1.9.2
    • Fix Version/s: 1.9, 1.9.11
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Environment:
      Google Chrome web browser
    • Affected Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      When viewing a page with the new Google Chrome web browser that contains the html editor (htmlarea) the html editing features don't appear; instead, a text box is displayed.

        Gliffy Diagrams

        1. chrome.patch
          2 kB
          Tariq Adel Ebrahim
        2. htmlarea-with-webkit-browsers.patch
          2 kB
          Jonathan Harker

          Issue Links

            Activity

            tariq.adel Tariq Adel Ebrahim created issue -
            tariq.adel Tariq Adel Ebrahim added a comment -
            korpelainen Mauno Korpelainen added a comment -

            It might be even possible to get latest version of Opera and Safari to render htmlarea properly by changing those functions that Tariq mentioned and tiny changes to code of htmlarea.php and css. I can confirm that Chrome works nicely with TinyMCE, FCKEditor, Xinha and also with htmlarea (at least most parts of htmlarea). I got also Opera 9.5 to render htmlarea with some possibly minor issues and the main problem with latest Safari is that toolbar is not fully visible (css) - otherwise htmlarea seems to be "almost functional" in Safari.

            tariq.adel Tariq Adel Ebrahim added a comment -

            Patch to detect 'Chrome' in $_SERVER['HTTP_USER_AGENT'] (./lib/moodlelib.php::check_browser_version()) and more or less the same thing done in ./lib/editor/htmlarea/htmlarea.php

            tariq.adel Tariq Adel Ebrahim made changes -
            Field Original Value New Value
            Attachment chrome.patch [ 15058 ]
            tariq.adel Tariq Adel Ebrahim made changes -
            Attachment chrome.patch [ 15059 ]
            tariq.adel Tariq Adel Ebrahim made changes -
            Attachment chrome.patch [ 15058 ]
            poltawski Dan Poltawski added a comment -

            Are you 100% sure all editor functions work with chrome?

            It is based on the same rendering engine as safari (though different js engine) so, its not unresonable to think that many things might be broken and it would be an unwise choice to enable it.

            The current editor has many bugs and I think its wise to be catious about enabling this new functionality - Matt is fixing it once and for all by getting rid the current buggy editor in 2.0.

            korpelainen Mauno Korpelainen added a comment -

            I'm 100% sure that all editor functions don't work with Chrome - how could they? Chrome & HTMLArea have similar bugs as other browsers and for example Dragmath plugin can be used with upgraded version of Java but equations are not posted to textarea, focus may sometimes get lost and so on. Like most other browsers Chrome has some personal shortcut keys so most Editor Shortcut Keys of HTMLArea don't work either. Although all basic buttons and features seem to work ok on my test site they should be tested on all environments - the current Chrome was released for Windows and they used components both from Apple's WebKit and Mozilla's Firefox.

            Still what do we loose if editor is enabled for Chrome? Button <> works well and it may be too optimistic to think that even Matt could fix it once and for all by getting rid the buggy editor in moodle 2.0. It's more likely an never ending story...new versions of editors and browers will always have bugs.

            scyrma Mathieu Petit-Clair made changes -
            Affects Version/s 1.9.1 [ 10240 ]
            Affects Version/s 1.9 [ 10190 ]
            Affects Version/s 1.8.5 [ 10252 ]
            Affects Version/s 1.8.4 [ 10242 ]
            Affects Version/s 1.8.3 [ 10230 ]
            Affects Version/s 1.8.2 [ 10220 ]
            Affects Version/s 1.8.1 [ 10213 ]
            Affects Version/s 1.8 [ 10130 ]
            Affects Version/s 1.7.4 [ 10243 ]
            Affects Version/s 1.7.3 [ 10212 ]
            Affects Version/s 1.7.2 [ 10174 ]
            Affects Version/s 1.7.1 [ 10151 ]
            Affects Version/s 1.7 [ 10120 ]
            Affects Version/s 1.6.6 [ 10211 ]
            Affects Version/s 1.6.5 [ 10210 ]
            Affects Version/s 1.6.4 [ 10150 ]
            Affects Version/s 1.6.3 [ 10140 ]
            Affects Version/s 1.6.2 [ 10119 ]
            Affects Version/s 1.6.1 [ 10118 ]
            Affects Version/s 1.6 [ 10110 ]
            danleighton Dan Leighton added a comment -

            This patch no longer seems to work with 1.9.5

            Any ideas please anyone?

            Many thanks

            chuang Wen Hao Chuang added a comment -

            Anyone tried to test the patch with 1.9.7? I suppose that it won't work for 1.9.7 either? Just curious, thanks!

            korpelainen Mauno Korpelainen added a comment -

            I don't know what Dan Leighton exactly ment but all basic features of HTMLArea seem to work with the latest moodle 1.9.7+ and Chrome. I did not test 3rd party plugins.

            There are just tiny css issues like button background color is a little darker in Chrome than in IE and FF but such things could be easily fixed by setting the background to some exact color instead of buttonface in lib/editor/htmlarea/htmlarea.css .

            Probably Dan had some problems with editing moodlelib.php and extra white spaces etc.

            Because current Chrome is handy and fast - much better than year ago - and also versions for Mac and Linux are available http://chrome.blogspot.com/2009/12/google-chrome-for-holidays-mac-linux.html it might be time to let Chrome run with lightning speed on moodle sites by default

            genner Genner Cerna added a comment -

            same here, editor is not working in google chrome

            genner Genner Cerna made changes -
            Priority Minor [ 4 ] Critical [ 2 ]
            jonathan Jonathan Harker added a comment -

            Hi there - I think it is better to check for the "AppleWebKit" version rather than the presence of the string "chrome" in the user agent. This will not only pick up Chromium but also a bunch of minority and mobile phone browsers that can cope fine - e.g. Konqueror, Safari, Symbian S60, Palm Pre, and so on, and ensure the correct version of WebKit. See attached patch.

            In testing I found Safari < 4.0 to not work with the textarea resizing, which is AppleWebKit < 528.16

            Cheers, J

            jonathan Jonathan Harker made changes -
            leebrent Brent Lee added a comment -

            Has anyone used this patch on 1.9.9+ ?

            nadavkav Nadav Kavalerchik added a comment -

            works fine in Moodle 1.9.9 after applying the second patch:
            http://tracker.moodle.org/secure/attachment/21204/htmlarea-with-webkit-browsers.patch

            danmarsden Dan Marsden made changes -
            Link This issue is duplicated by MDL-24626 [ MDL-24626 ]
            smithrn Ryan Smith added a comment -

            Are there any plans to add this patch to the 1.9.x branch soon? More and more users are trying to use Chrome and Safari especially Chrome) and it is really frustating that they cannot. This bug has been open for over 2 years.

            chuang Wen Hao Chuang added a comment -

            +1 for adding this patch to 1.9.x branch...

            rezeau Joseph Rézeau added a comment -

            Just noticed something strange today.

            On moodle.org (now using moodle 2.0) the HTLM editor is not working in Windows chrome.

            On my moodle local test site:

            moodle 1.9.10 : HLML editor not working in Chrome
            Moodle 2.0 RC1 (Build: 20101112) : TinyMCE editor working fine in Chrome

            Why is TinyMCE editor NOT working in Chrome for moodle.org ???

            rwijaya Rossiani Wijaya added a comment -

            Hi Joseph,

            Thank you for reporting. HTML editor works with my Windows Chrome.

            Thanks for the patch Jonathan. I will add the patch to 1.9.

            rwijaya Rossiani Wijaya made changes -
            Fix Version/s 1.9 [ 10190 ]
            rwijaya Rossiani Wijaya made changes -
            Assignee Mathieu Petit-Clair [ scyrma ] Rossiani Wijaya [ rwijaya ]
            gavinmc Gavin Mccullagh added a comment -

            Hi,

            I've applied htmlarea-with-webkit-browsers.patch to our Moodle v1.9.9 install here. It seems to fix the problem alright. we haven't noted any negative side effects so far.

            Gavin

            smithrn Ryan Smith added a comment -

            No need to apply the patch anymore....Rossiani checked the patch into the MOODLE19_STABLE branch last week....it works great!

            rwijaya Rossiani Wijaya added a comment -

            Thank you Gavin and Ryan for testing the patch.

            Patch has been checked-in to 1.9_stable.

            Resolved.

            Rosie

            rwijaya Rossiani Wijaya made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            skodak Petr Skoda made changes -
            Link This issue has been marked as being related by MDL-25591 [ MDL-25591 ]
            skodak Petr Skoda added a comment -

            hmm, this change creates a serious regression for iPad users - see MDL-25591, also the fix version is wrong.

            skodak Petr Skoda made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            Fix Version/s 1.9.11 [ 10410 ]
            skodak Petr Skoda made changes -
            Status Reopened [ 4 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            dougiamas Martin Dougiamas made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            dougiamas Martin Dougiamas made changes -
            Workflow jira [ 28264 ] MDL Workflow [ 60767 ]
            pedicini Lisa Pedicini added a comment -

            Petr – Am I understanding you correctly that version 1.9.11 will break the HTML editor in inexplicably works in 1.9.10+ with Safari? I am thrilled (thrilled!) that a fix has finally been found to make Moodle and Safari play nicely and don't want to do anything that would jeopardize their new found happiness together. But I do want this patch for the questionnaire:http://tracker.moodle.org/browse/CONTRIB-2200

            My host is asking if I just want to upgrade to 1.9.11. It sounds as if I just want the patch, yes?

            pedicini Lisa Pedicini added a comment -

            Sorry - s/b the HTML editor that inexplicably works in 1.9.10+ with Safari?

            dougiamas Martin Dougiamas made changes -
            Workflow MDL Workflow [ 60767 ] MDL Full Workflow [ 89947 ]
            pacsolution Takayuki Fuwa added a comment -

            I'm using 1.9.10, but doesn't works HTML editor on Google Chrome(Ver:11.0.696.65).

            I can't understand about "This ticket is closed".


              People

              • Votes:
                19 Vote for this issue
                Watchers:
                20 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  3/Mar/08