Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-16345

Moodle 2.0 question bank improvements

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.2.10
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE

      Gliffy Diagrams

        Attachments

          Issue Links

            Activity

            timhunt Tim Hunt added a comment -

            Need to create further subtasks in addition to the two linked issues.

            ppichet Pierre Pichet added a comment -

            Correct a problem of courseid reference for preview in question bank , put this here as I did not know where to put it and did not have the time to search more....

            timhunt Tim Hunt added a comment -

            Thanks Pierre. I am still half way through this work. I must get it finished soon, and then test some more.

            ppichet Pierre Pichet added a comment -

            'half way through this work'
            and this is a lot of work...

            rcollman Chris Collman added a comment -

            Hi Tim,
            Any chance for a "comment" field for each question in 2.0 or 2.1. This would allow a question creator or someone else to put a source and perhaps how the question related to their lesson plan. Then in IA we could have a switch that would display comments or export them. Just being able to see the field in a question edit mode would be a big help.

            This is very important in some subjects, like formative tests in a certified training environment. Have to believe that academia could use it to tie to a Lesson Plan or a rule(s) or book and page number.

            timhunt Tim Hunt added a comment -

            Chris, good idea, but an entirely separate feature request. Please file it as such.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Hi Tim,

            was creating some test questions (true-false) when I've ended with some problems in the questionbank. To reproduce:

            • create one quiz and add one true/false question into own module category, setting the correct answer to true. Save the question.
            • PROBLEM1: preview the question. The feedbacks (or the correct answer evaluation) seems to be wrong.
            • Edit the question created above, PROBLEM2: Everything in the interface (breadcrumb, save and cancel buttons...) lead to not found URL: The requested URL /~stronk7/git/http://127.0.0.1/~stronk7/git/mod/quiz/edit.php was not found on this server.
            • Also, when editing the question, PROBLEM3: official tags don't seem to be available (and I've a bunch of them in my test site).

            Not sure if those problems belong to this issue or no, but they render the edition of (truefalse for now) questions unusable.

            Ciao

            timhunt Tim Hunt added a comment -

            These changes were done ages ago.

            There is more work to be done on the question bank in future, but that is being tracked at MDL-27794.


              People

              • Votes:
                6 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  13/May/13