Moodle
  1. Moodle
  2. MDL-16375

Students unable to "start new discussion topics" or subscribe to old forums

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.9.1, 1.9.2
    • Fix Version/s: None
    • Component/s: Forum
    • Labels:
      None
    • Environment:
      MySQL
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      9474

      Description

      After upgrading to 1.9.2 - my students are unable to do the following:

      1. Start a new discussion topic in any forum
      (They are able to reply to discussions created by teachers, but not create their own)
      I have checked the permissions and tried over-riding it as well, but the error continues.

      2. Subscribe to forums that existed before the upgrade.
      (For example, all of my new students cannot see or subscribe to the "Site News" on the main page.)

        Issue Links

          Activity

          Antti Alamäki added a comment -

          This bug seems to be the case also on a clean moodle 1.9.2 install, the same issue affects version 1.9.1.

          Antti Alamäki added a comment -

          Ok,

          I believe I have traced down the cause of the issue, in lines 4261 - 4265 of the file /mod/forum/lib.php it says something like

          if ($currentgroup)

          { return groups_is_member($currentgroup); }

          else

          { // no group membership and no accessallgroups means no new discussions // reverted to 1.7 behaviour in 1.9+, buggy in 1.8.0-1.9.0 return false; }

          To solve this issue at least temporarily, turn on the "access all groups" under the system role "Student" settings (not enabled by default).

          I believe this is still a bug and not meant to work this way but at least it does provide a temporary workaround, not sure what are the consequences of enabling this option.

          Other option is to change the "return true" into "return false" but I doubt this is a good idea.

          Martin Dougiamas added a comment -

          Hi!

          To help us track this down, can you tell us how you have groups-related settings configured for that course?

          Antti Alamäki added a comment -

          Hi,

          I simply logged in as admin user and added a group in the settings for the course and then added this user to that group with no enrolment key, I cannot see any other group-related settings for the course.

          Also double-checked that the user has been assigned the role "student" for the course, I now in the forum tried to add posts that would be visible for just this group but it says "Adding discussions to this forum requires group membership."

          Antti Alamäki added a comment -

          Hi,

          It appears that now the way which I had done it works, when I create a group in the course and then assign the student a membership in that group, the user is able to post 1 discussion topic to the forum.

          I feel that this is still a bug as we have set it up in the forum module settings so that students can post a topic. This should not require membership in a group as it does not require for a teacher either.

          Christopher added a comment -

          As far as my moodle - there are no groups setup at all.

          Petr Škoda added a comment -

          hello,
          this is most probably a problem with groups settings - if you enable separate groups you must divide your students into groups if you want them to access forums in separate groups mode

          petr


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: