Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-16985

Backup and restore totally broken in HEAD and has been for months

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Backup
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      In 2.0, when I click on "restore" in the course admin box, I am shown the course files. But there is no button or link to select the files for restore. I only have "Download", "View in a popup window" and "Delete".

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda added a comment -

              sure, this is not yet implemented - nobody started working on backup/restore yet

              ahutton ann hutton added a comment -

              I have this same issue...major bummer as I was planning on restoring courses from my older slower moodle to this newer faster moodle. Please, please, please... could someone fix this.
              Thank you.

              skodak Petr Skoda added a comment -

              unless you are a developer you should be using 1.9.X not 2.0dev

              this is not a bug, clearly this is a work in progress

              timhunt Tim Hunt added a comment -

              Please fix!

              skodak Petr Skoda added a comment -

              I am not going to work on backup/restore until the enrolment changes are confirmed or rejected.

              emb03 Elaine Blakeman added a comment -

              Any update on this status of this fix? I am piloting 2.0 and mahara and it sure would help not to have to re-create whole courses but use an existing one.

              dougiamas Martin Dougiamas added a comment -

                People

                • Votes:
                  10 Vote for this issue
                  Watchers:
                  11 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    24/Nov/10