Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Administration
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      30296

      Description

      You get loads of warnings like:

      Warning: it's not recommended to use $text parameter in helpbutton ($page=, $module=) function

      • line 5930 of lib/weblib.php: call to debugging()
      • line ? of unknownfile: call to helpbutton()
      • line 67 of lib/form/text.php: call to call_user_func_array()
      • line 1226 of lib/formslib.php: call to MoodleQuickForm_text->setHelpButton()
      • line 1277 of admin/generator.php: call to MoodleQuickForm->setHelpButton()
      • line 111 of lib/formslib.php: call to generator_form->definition()
      • line 1187 of admin/generator.php: call to moodleform->moodleform()
      • line 1298 of admin/generator.php: call to generator_web->setup()

      which is excusable in a script like this, but then you get:

      Catchable fatal error: Argument 6 passed to postgres7_adodb_moodle_database::connect() must be an array, string given, called in /home/tim/Workspace/moodle_head/admin/generator.php on line 165 and defined in /home/tim/Workspace/moodle_head/lib/dml/postgres7_adodb_moodle_database.php on line 12

      which is a bit of a show-stopper.

        Issue Links

          Activity

          Hide
          Petr Škoda added a comment -

          the db connection regression fixed, going to clone it to separate the first issue

          Show
          Petr Škoda added a comment - the db connection regression fixed, going to clone it to separate the first issue
          Hide
          Petr Škoda added a comment -

          thanks and sorry

          Show
          Petr Škoda added a comment - thanks and sorry
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Fixed also in windows installer. Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Fixed also in windows installer. Ciao
          Hide
          Sam Hemelryk added a comment -

          Once again broken in HEAD, will commit a patch in a couple of secs to get it up and running
          but maybe someone would like to take a proper look at this.

          Show
          Sam Hemelryk added a comment - Once again broken in HEAD, will commit a patch in a couple of secs to get it up and running but maybe someone would like to take a proper look at this.
          Hide
          Sam Hemelryk added a comment -

          Generator is up and running again, however it seems to have some real performance issue with larger generation.
          When generating for 20+ courses with full information it chewed up APACHE and sometime didn't finish the job.
          Perhaps someone who is more familiar with this could check it out...
          Cheers Sam

          Show
          Sam Hemelryk added a comment - Generator is up and running again, however it seems to have some real performance issue with larger generation. When generating for 20+ courses with full information it chewed up APACHE and sometime didn't finish the job. Perhaps someone who is more familiar with this could check it out... Cheers Sam

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: