Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-17122

Installation: cannot install Moodle with Postgres (Ubuntu) without tricking the installation

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.3
    • Fix Version/s: 1.9.4
    • Component/s: Installation
    • Labels:
      None
    • Environment:
      Ubuntu - Postgres8 - Apache
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      I installed Postgres8 on Ubuntu (http://docs.moodle.org/en/Installing_Postgres_for_PHP)
      Then I checked out a fresh Moodle 19 Stable

      During the Moodle installation process, on the database page I had to enter into the HOST field:
      host='localhost' port=5432 dbname='moodle' user='moodleuser' password='password'

      If I tried to use the other fields (use,password,database) that I would expect to be used, I had a message: 'Can not connect to the database'.

      I guess it could be a problem of the missing port field...

      We could either fix it, either add some more information on this page in order to help the administrator.

        Attachments

          Activity

            People

            Assignee:
            jerome Jérôme Mouneyrac
            Reporter:
            jerome Jérôme Mouneyrac
            Tester:
            Eloy Lafuente (stronk7)
            Participants:
            Component watchers:
            Matteo Scaramuccia, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              28/Jan/09