Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-17189

Creating an assignment with "no grades" still creates a grade item in the gradebook

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.9.3
    • Fix Version/s: 1.9.4, 2.0
    • Component/s: Assignment (2.2), Gradebook
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Gliffy Diagrams

        Attachments

          Issue Links

            Activity

            nicolasconnault Nicolas Connault added a comment -

            Actually this is probably not a bug. Even though grading is disabled for an assignment, it is still possible to give textual feedback to the students through the assignment interface. This must be recorded in the gradebook, so there must be a grade item for it.

            kiddlisa Lisa Kidder added a comment -

            I know this is closed, but now that Assignment 2.2 has more control over the feedback, could that also control whether it shows up in the gradebook? So if all the feedback is set to "no" then there is no grade item in the gradebook.

            The Blackboard Collaborate plugin is based on this code, so it is adding an item in the gradebook for every activity added to the course, even when it is set to no grade. It has made for some very confused instructors.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  28/Jan/09