Sorry, this one is quite big. I don't know why I did not notice it before.
We really should not be adding our code to the YAHOO library namespace. I would change
YAHOO.cats.container -> question_bank
YAHOO.quiz.container -> quiz_editor
or something like that.
<div id="module" is not very descriptive. Wouldn't something like id="questionbankcontents" be better?
Do you really want to initialise on load, would onDomReady work better?