Moodle
  1. Moodle
  2. MDL-17675

Advanced assignment will not display respomse file to student unless a grade or comment is also suppllied

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.9.3
    • Fix Version/s: None
    • Component/s: Assignment (2.2)
    • Labels:
      None
    • Environment:
      Apache 2, MySQL 5, PHP 5.2.6
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      2275

      Description

      We have a client that we have recently upgraded from Moodle 1.8 to 1.9.3+

      Previously, in using the advanced assignment type, their teachers were able to take a studen't uploaded file submission, reead it, insert comments into the file and then re-upload it as a response file for the student to see - all of the feedback and any grade items were put in the file, and not put in the assignment mosule. This worked fine.

      Now, on 1.8.3+, the response file will not be displayed to the student unless the teacher has supplied a grade or feedback through moodle as well. This could be anything, even just a full-stop in the feedback box, but something has to be there - and most teachers forget ot as they are used to not having to so this.

      Is this an intentional change or a bug?

      Sean K

        Issue Links

          Activity

          Ray Lawrence added a comment -

          This was intentional AFAIK. The workflow in has changed in 1.9.x

          Your client can hide the file etc. in the new gradebook if this is what is required.

          Tony Butler added a comment -

          This has caused a lot of confusion recently for a few of our teachers, because the behaviour didn't seem to be consistent - some students could see the response files (even without a grade or comment) and others could not.

          I eventually figured out that the response file is displayed if the teacher simply uploads it and then closes the feedback pop-up window without saving. However if the teacher uploads the file(s) and then clicks one of the Save buttons without typing a comment or awarding a grade, then the file is not displayed to the student.

          Because of this inconsistency it seems improbable to me that this is intentional, and much more likely a bug.

          Tony Butler added a comment -

          The attached patch fixes it.

          Ray Lawrence added a comment -

          Hi Tony,

          What's the behavior if the patch is applied?

          Tony Butler added a comment -

          Hi Ray,

          With the patch applied, if the teacher uploads a file and clicks save (without typing a comment or awarding a grade) the file is displayed to the student - exactly the same as when the teacher uploads a file and then closes without saving.

          This must surely be the intended behaviour IMO. I can't imagine why a teacher would upload a file and click save, and not expect it to be displayed to the student. Certainly our teachers have this expectation.

          Cheers,
          Tony

          Ray Lawrence added a comment -

          Thanks.

          To be honest I can think of a number of other reasonable expectations (which should be properly considered feature request rather than being lumped into this issue).

          Atm, the key thing that there is consistency on the display of the response files.

          Cheers

          Ray

          Rossiani Wijaya added a comment -

          This issue will be resolved by MDL-16553.

          Closing as duplicate issue.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: