Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-17863

mnet_host.portno field unable to hold port number higher than 255 in mysql (making https impossible)

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 1.9.3, 2.0
    • 1.9.8, 2.0
    • MNet
    • None
    • Ubuntu 8.04.1
      mysql Ver 14.12 Distrib 5.0.51a, for debian-linux-gnu (i486)
      PHP 5.2.4-2ubuntu5.3 with Suhosin-Patch 0.9.6.2 (cli) (built: Jul 23 2008 06:44:49)
    • MySQL
    • MOODLE_19_STABLE, MOODLE_20_STABLE
    • MOODLE_19_STABLE, MOODLE_20_STABLE
    • Moderate

    Description

      Integration BTW Moodle 1.9.3+ (2007101533.01) and Mahara 1.0.8 works fine with https & postgresql, but https & mysql is broken. The reason appears to be that neither app is able to store port 443 in mysql.

      Database install.xml version 20081010 says:

      <FIELD NAME="portno" TYPE="int" LENGTH="2" NOTNULL="true" UNSIGNED="true" DEFAULT="0" SEQUENCE="false" ENUM="false" PREVIOUS="transport" NEXT="last_connect_time"/>

      I recommend LENGTH="10" instead.

      This is also affecting Mahara downstream; see Mahara bug #3097 ( http://eduforge.org/tracker/?func=detail&atid=739&aid=3097&group_id=176 ).

      ...I was testing this to be sure this was sufficient to fix the problem, but I ended up taking a guess and setting 443 manually after setting up the integration, and it still didn't work. I just gave up and will use postgresql instead.

      Attachments

        Issue Links

          Activity

            People

              mjollnir Penny Leach
              moquist Matt Oquist
              Andrew Davis Andrew Davis
              David Woloszyn, Huong Nguyen, Jake Dallimore, Michael Hawkins, Stevani Andolo
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                25/Mar/10