Moodle
  1. Moodle
  2. MDL-1791

Can't add links to images in HTML editor

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4
    • Fix Version/s: None
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_14_STABLE

      Description

      I tried to add a link to an image in the HTML editor today but no many how many times I pressed the link button, the link window would not appear unless I selected some text.

      I am pretty sure I have succeeded in linking to an image using the HTML editor in the pasy, by first inserting the image, then clicking the image so that their are little white sqares around it, then clicking link. But today, nothing.

      You might consider added a link to field in the image insertion window.

        Gliffy Diagrams

          Activity

          Martin Dougiamas added a comment -

          From Martin Dougiamas (martin at moodle.com) Wednesday, 25 August 2004, 12:41 PM:

          I can confirm this ... I think it's new too. Janne?

          From Janne Mikkonen (janne.mikkonen at julmajanne.com) Wednesday, 25 August 2004, 08:06 PM:

          Yes I've notice this problem. It became when selection test were added. There must be also check if image is selected so you can also add links to images.

          From Timothy Takemoto (timothy at nihonbunka.com) Wednesday, 25 August 2004, 09:46 PM:

          Are the selection tests absolutely necessary?

          I ask because it would be nice to be able to add a link (or rather an embed, after filtering) to a null selection as mentioned (empty links) here:

          http://moodle.org/mod/forum/discuss.php?d=11498&parent=55624

          From Janne Mikkonen (janne.mikkonen at julmajanne.com) Friday, 27 August 2004, 04:54 AM:

          Fixed. You can add links to images again now.

          No embedding. That change should be reported as a feature request.

          From Timothy Takemoto (timothy at nihonbunka.com) Friday, 27 August 2004, 09:32 AM:

          Dear Janne,

          Thank you very much for your kind attention to this problem.

          Sadly, however, I am afraid that I cannot add links to images still. Instead of getting the message You must select text first I get a message in the status bar at the bottom saying page error. The below is a screen capture of this event.

          http://tim.econo.yamaguchi-u.ac.jp/temp/add_link_to_image.jpg

          It used to be possible, only a few days ago, to add links to images, because I did it in a TOEIC course full of listening questions.

          I will add a feature request for the embedding but please consider it a very low priority. If I can link to images then that is fine.

          Tim

          From Janne Mikkonen (janne.mikkonen at julmajanne.com) Friday, 27 August 2004, 02:47 PM:

          Hi Tim

          This is indeed fixed just update your copy (from stable MOODLE_14_STABLE branch) clear your browser cache and try it again.

          You're just between versions. First commit I made last night did't include this fix, but did committed it in shortly after that.

          It is possible to add links to images but not edit them (not a bug, feature, might be fixed in 1.5)

          Michael Blake added a comment -

          assign to a valid user


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: