Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-18012

showall -> showallusers in admin/roles/assign.php

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.9.3
    • Fix Version/s: 1.9.14
    • Component/s: Roles / Access
    • Labels:
      None
    • Testing Instructions:

      1/ Go to assign roles screen
      2/ Search for user
      3/ Notice the 'show all users' button (before this change, the button said 'show all'

      Show
      1/ Go to assign roles screen 2/ Search for user 3/ Notice the 'show all users' button (before this change, the button said 'show all'
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Pull from Repository:

      Description

      This is a very little bug.

      in admin/roles/assign.php

      $strpotentialusers = get_string('potentialusers', 'role');
      $strexistingusers = get_string('existingusers', 'role');
      $straction = get_string('assignroles', 'role');
      $strroletoassign = get_string('roletoassign', 'role');
      $strsearch = get_string('search');
      $strshowall = get_string('showall'); <- Here!
      $strparticipants = get_string('participants');
      $strsearchresults = get_string('searchresults');

      Please change
      $strshowall = get_string('showall');
      to
      $strshowall = get_string('showallusers');
      since get_string('showall') needs a parameter.

      There are no influences in english environment([Show all]), but a strange string is displayed in Japanese environemt .

        Gliffy Diagrams

          Attachments

            Activity

            poltawski Dan Poltawski added a comment -

            Sorry its taken me so long to get to this.

            I'm not optimistic will accept this change into the 19_STABLE branch now - as we are only doing basic maintainance. However, I will submit this for integration anyway.

            dougiamas Martin Dougiamas added a comment -

            -1 as there might be unintended regressions in other languages, the benefit isn't worth the risk IMO

            shirai Tatsuya Shirai added a comment -

            screen shot when using showall,

            shirai Tatsuya Shirai added a comment -

            language pack (moodle.php)

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The integration of this issue has been delayed to next week due to time constraints. Thanks for your support and patience!

            Sorry and ciao

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks.

            This link revealed the string is widely available in all major 1.9 lang packages:

            http://lang.moodle.org/local/amos/view.php?t=1313503349&v=1900&l=%2A&c=moodle&s=&d=showallusers

            rajeshtaneja Rajesh Taneja added a comment -

            "Show all users" is visible.
            Thanks for fixing this Tatsuya and Dan

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Such an effort has get its prize. Universal Award to the very-best Moodle developer in the family. Thanks!

            Closing. Ciao


              People

              • Votes:
                2 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Oct/11