Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-18012

showall -> showallusers in admin/roles/assign.php

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.9.3
    • Fix Version/s: 1.9.14
    • Component/s: Roles / Access
    • Labels:
      None
    • Testing Instructions:
      Hide

      1/ Go to assign roles screen
      2/ Search for user
      3/ Notice the 'show all users' button (before this change, the button said 'show all'

      Show
      1/ Go to assign roles screen 2/ Search for user 3/ Notice the 'show all users' button (before this change, the button said 'show all'
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Pull from Repository:

      Description

      This is a very little bug.

      in admin/roles/assign.php

      $strpotentialusers = get_string('potentialusers', 'role');
      $strexistingusers = get_string('existingusers', 'role');
      $straction = get_string('assignroles', 'role');
      $strroletoassign = get_string('roletoassign', 'role');
      $strsearch = get_string('search');
      $strshowall = get_string('showall'); <- Here!
      $strparticipants = get_string('participants');
      $strsearchresults = get_string('searchresults');

      Please change
      $strshowall = get_string('showall');
      to
      $strshowall = get_string('showallusers');
      since get_string('showall') needs a parameter.

      There are no influences in english environment([Show all]), but a strange string is displayed in Japanese environemt .

        Attachments

          Activity

            People

            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                10/Oct/11