Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-18347

Correct lesson short answers not incrementing student score

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.9.4
    • Fix Version/s: 1.9.5
    • Component/s: Lesson
    • Labels:
      None
    • Environment:
      php 5.2.8, V1.9.4+ (Build: 20090218), MySQL 5.0.67-community, Apache 2.2.11 (Unix), Perl 5.8.8, Operating system Linux Kernel 2.6.28
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      Any time a question includes a short answer, the question attempt is recorded. However, the response is not recorded as correct even if it was correct. This causes the student score to be incorrect. The lesson pages process correctly. The correct feed back is displayed. Everything appears to work perfectly, except that he total score for the lesson is not incremented properly.

        Gliffy Diagrams

          Activity

          cgkel Carl Keller added a comment -

          I can provide a URL for this if you are interested. I just did not want it publicly displayed.

          cgkel Carl Keller added a comment -

          There appears to be a connection between these two issues.

          paaskynen Paul Nijbakker added a comment -

          We are experiencing this same bug since our upgrade to version 1.9.4. It occurs in lessons in which questions are not custom graded. I hope it can be fixed. In the meantime I am checking my lessons and turning those with short answer questions to custom grading.

          cgkel Carl Keller added a comment -

          HI!

          Is anyone actively working on this issue? We have online courses that rely heavily on the lesson module, and they are crippled over this!

          Thanks!

          bushido Mark Nielsen added a comment -

          I was able to reproduce the bug. Attached is a patch that fixes the bug and also fixes a notice that would appear at the end of the lesson when you type in an answer for the short answer question type that does not match any of the expected answers.

          If someone could test the patch, that would be great. I tested it with custom scoring on and off and with a single correct and wrong answer.

          bushido Mark Nielsen added a comment -

          Committed the patch.

          jerome Jérôme Mouneyrac added a comment -

          My test on 1.9:
          I created a lesson with one Short Answer question page.
          On this short answer question, I set one answer to score 10, another to score 21
          As a student I answer the question with the score 10, the score and average are well displayed. Teacher can see the good score too.
          Fixed.

          Thank you for the report and the fix.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                13/May/09