Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-18414

Sharing a category and multiple courses over mnet does not work

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9, 1.9.1, 1.9.2, 1.9.3, 1.9.4
    • Fix Version/s: 1.9.5, 2.0
    • Component/s: MNet
    • Labels:
      None
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      If an mnet administrator chooses to share all courses, things work fine,
      If an mnet administrator chooses to share a category of courses (or several), and up to one course, things work fine.

      If an mnet administrator chooses to share no categories and a list of courses, things work fine.

      If an mnet administrator chooses to share one or more categories, and more than one course, the wheels come off due to incorrectly formed sql query passed to the database.

      Confirmed that postgres throws an error in this situation. Mysql / others unknown.

        Gliffy Diagrams

          Attachments

            Activity

            skodak Petr Skoda added a comment -

            Is this fixed?

            peterbulmer Peter Bulmer added a comment -

            Yes, thanks for the reminder Petr


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  13/May/09