Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.9.4
    • Fix Version/s: None
    • Component/s: General
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      1025

      Description

      List of compatibility issues with newly released IE8, as much as possible should be fixed in stable 1.9.x, 1.8.x might get some fixes too.

      Please add new isses as subtasks.

        Issue Links

          Activity

          Mauno Korpelainen added a comment -

          I think the main problem is how moodle uses window.open method in different javascripts. The fix should do something like in

          http://support.microsoft.com/kb/269658

          Mauno Korpelainen added a comment -

          That link is about IE5.5 but there are several reports about IE8 breaking window.open method is you google ie8 "window.open "

          Mauno Korpelainen added a comment -

          This popup issue is not caused by code of moodle - the reason why IE8 doe not open popups and certain type of links is in install process of IE8 itself = IE8 bug.

          In my case (IE8 on Windows Vista) the problem was solved with the procedure suggested by Eisenb11 at microsoft.public internetexplorer.beta group:

          Goto command prompt (start menu – programs – accessories) and
          run as administrator (or use 'Run ...' as administrator).

          Type the following command:

          regsvr32 actxprxy.dll

          For some unknown reason Vista had not registered this dll
          during installation.

          Let's wait that Microsoft changes the install code of it's programs and current windows.open tags should work ok.

          Mauno Korpelainen added a comment -

          I could test this bug only with Vista but Microsoft had a similar problem with IE5 and IE6 and regsvr32 actxprxy.dll may not be the only improperly registered dll file in IE8

          http://support.microsoft.com/default.aspx?scid=kb;en-us;Q281679

          So somebody can test IE8 in Windows XP or Windows 2000 and if history repeats itself and using

          regsvr32 actxprxy.dll

          does not help you may need to register some other dll files with command

          regsvr32 urlmon.dll

          or in some cases

          regsvr32 scrrun.dll
          regsvr32 msxml.dll
          regsvr32 mshtml.dll
          regsvr32 shdocvw.dll
          regsvr32 browseui.dll
          regsvr32 msjava.dll

          And note that at least in Vista you will need to use a command prompt that is executed as ADMINISTRATOR of that PC (until Microsoft has released some hotfix)...

          Anyway it looks like this meta bug can be closed as "Not a bug - it's only IE"

          Jose Cedeno added a comment -

          I'd strongly suggest waiting to worry about IE8 until its reaches a significant percentage of market share.

          Ryan Smith added a comment -

          Waiting until it reaches a significant market share is simply the wrong approach. It is a released, final version of the IE browser and it is a significant improvement on IE6 and IE7.

          Also, it will be released on Windows Update the week of April 13. On April 27, it becomes an automatic Windows update.

          Why not fix the issues now and support IE8 users?

          Wen Hao Chuang added a comment -

          I agree with Ryan, I think this issue should be fixed ASAP (IMHO)...

          Mauno Korpelainen added a comment -

          Well how do you fix a bug that is not in the code of moodle but in the code of IE8 installer script?

          ALL of these issues were fixed when I ran the command

          regsvr32 actxprxy.dll

          in my Vista command prompt as Administor of my PC.

          I don't know if the reason for failure of registration of some dll files can be caused by some custom plugins in IE (google stuff etc) but missing = unregistered dll file(s) is/are the only reason for these issues.

          • window.open method is totally valid javascript but if IE8 has not registered that dll file popups and some links fail to open

          All we can do is to wait that Microsoft fixes the installer script although IE8 is really the default browser of Windows already - http://www.microsoft.com/windows/internet-explorer/default.aspx

          Jose Cedeno added a comment -

          I'm just not a fan of IE, and it seems from the discussion so far that this bug can be closed since it cannot be 'fixed' by moodle developers.

          Mauno Korpelainen added a comment -

          Let's hope MS will fix this some day...

          The only problem with typing

          regsvr32 actxprxy.dll

          in command prompt is that you really need to run it as administrator or Vista won't allow the registration change.

          So when you run from start menu – programs – accessories – command prompt , use mouse right click and
          Run as administrator (or use 'Run ...' as administrator) to get it done properly.

          Mauno Korpelainen added a comment -

          As an example how to do the registration of that dll file read for example

          http://www.edbott.com/weblog/?p=2443

          Mauno Korpelainen added a comment -

          And although that blog tells you to restart your PC restarting should not be necessary - at least my Vista repairs IE8 immediately without restarting...

          Ryan Smith added a comment -

          You can't expect people to be able to register a DLL to fix the issue. Also, that "fix" is pretty controversial at this point. That link you sent even says "I have contacted some engineers at Microsoft to see if they can shed light on the issue and will follow-up after I hear from them." So lets wait and see on the DLL "issue".

          I feel that the best solution to this entire meta is to force EmulateIE7. That way it can be removed once these issues are sorted out.

          <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

          Even http://www.microsoft.com is doing this.

          See:

          http://ajaxian.com/archives/x-ua-compatible-ieemulateie7

          Mauno Korpelainen added a comment -

          I don't think it is a good option anymore - I suggested it a year ago - but emulating IE7 was a safe solution only when MS tested IE8 alpha and beta and they use it in MS to avoid total crash of browsers for those people who use beta versions of IE8.

          I agree that you can't expect people to be able to register DLL files - Microsoft should do it for you - after some months...

          That's why I have said it 3 times already - this is a bug in IE8, not in moodle, and MS should repair IE8.

          We can as well tell people to totally remove Windows upgrade IE8 - it is not even listed in Programs list in Control panel...

          Mauno Korpelainen added a comment -

          Another reason why Microsoft should fix this - not moodle - is that those meta tags change the css behaviour http://tracker.moodle.org/browse/MDL-14258 but here the main problem is in javascripts and missing dll files of IE8.

          You should notice the problem even in Resource Manager of Windows where popup windows are sometimes opened when you expect no new windows etc. If dll files are working you can see the same behaviour as with IE7.

          Ryan Smith added a comment -

          If I go to 'Uninstall a program' in Vista Control Panel then click 'view installed updates' Windows Internet Explorer 8 is listed and offers an uninstall option....

          BTW, it looks like code-contributor Matthew Davidson has fixed http://tracker.moodle.org/browse/MDL-18232 where the section links don't work in IE8.

          Mauno Korpelainen added a comment -

          Yes - well my Control Panel is written in finnish so "remove Windows upgrade IE8 - it is not even listed in Programs list in Control panel..." should mean exactly the same as your correct words, Ryan...

          It's true that the fix in http://tracker.moodle.org/browse/MDL-18232 works, but if moodle is planning to stop IE6 support - for example Tinymce won't support IE6 anymore in 2010 - we may have hard times with IE8 that behaves like IE6 or IE5.5 unless you use it in IE7 mode or register dll files.

          I still think that IE8 stable is not at all stable...

          Ryan Smith added a comment -

          IE8 is considered a Windows Update, NOT an application, thus it isn't listed in the control panel add/remove programs. You have to click the 'View installed updates' link in the tasks pane. It should be there regardless of language.

          http://www.scottgu.com/blogposts/sp1vista/step1.jpg

          that is a screenshot of what I see. Sorry for the language barrier!

          Mauno Korpelainen added a comment -

          Yes - and I'm just trying to say that we are talking about the same "thing" - I have removed and re-installed this blody IE8 Windows Update about 10 times already...from the first alpha to this last "stable" one...

          Susan Mangan added a comment -

          Can someone confirm if this is the right bug to watch for IE8 fixes? I initially reported an issue back in June here: http://tracker.moodle.org/browse/MDL-19396 but there was no response.

          Upon searching further I found another bug: http://tracker.moodle.org/browse/MDL-14258 and posted a comment.

          But then I found this bug thread ...

          Our institution will not be upgrading to IE8 until late next year at the earliest but there are already many faculty prepping for the Fall term who have upgraded their home computers and laptops and I anticipate many students will as well. I am currently asking them to install firefox in the interim but I don't anticipate a lot of satisfaction with this resolution!

          We are running Moodle v.1.8+.

          Thanks for any information you can provide...

          Susan Mangan

          Mauno Korpelainen added a comment -

          What can I say... have you tried to install IE8 and test yourself if those problems still exist?

          This is not a bug in any version of moodle - it was and still may be a bug in IE8 and can be fixed by registering the missing dll files if upgrading of Internet Explorer for some unknown reason can't do it itself. It explains all such issues where you try to open some popup windows or certain types of links and can't because IE8 has not registered the dll file that controls those actions. My IE8 has worked perfectly well with all versions of moodle since April (when I typed that command to command prompt as administrator of my Vista).

          Here you have one fresh link from official Microsoft Help and Support if you don't believe what I have tried to say about 10 times:

          http://support.microsoft.com/kb/902932/en-us

          Ryan Smith added a comment -

          That Microsoft KB902932 link does not apply, it is specifically for IE6 and IE7.

          Mauno Korpelainen added a comment -

          Ryan and Susan,

          have you tried to force IE8 to compatibility view and to play IE7?

          In order to enable and turn on Compatibility View mode for all web pages and websites, click on Tools menu, and select Compatibility View Settings. In the "Compatibility View Settings" dialog, tick the check box for Display all websites in Compatibility View option. Click on Close button when done.

          Ryan will probably say next that this is not a solution for anything because IE8 must be IE8 but some problems can be at least prevented with compatibility view settings or properly registered dll files.

          In a long run developers may need to start changing the code of moodle to support IE8 and IE9 but it sounds like a really bad idea to start removing and fixing such valid javascript or XHTML that works correct on all other browsers than IE8 ( unless it is in compatibility mode and works like IE7 ) - just because Microsoft has decided to validate only their own rules...

          Ryan Smith added a comment -

          The section links block works as designed on IE8 if you turn on Compatibility View. I believe some websites force IE8 into Compatibilty View using a header tag.

          Mauno Korpelainen added a comment -

          Yes but the strangest thing of all is that

          <META HTTP-EQUIV="X-UA-COMPATIBLE" CONTENT="IE=EmulateIE7">

          does not have the same effect as changing the actual settings of browser

          Mauno Korpelainen added a comment -

          I have tested that meta tags several times in theme meta.php and it never works but as soon as I select Display all websites in Compatibility View option from Compatibility View Settings dialog IE8 seems to work correct like IE7 - maybe Microsoft.com is the only site that is actually using this meta tag...

          Mary Parke added a comment -

          I will file this as a separate tracker MDL-20338 but believe it should be related to this tracker as well.

          • IE8 is causing problems with secure quizzes with limited number of questions available per page as described below:

          IE 8 is requesting "allow access to the clipboard" when a student attempts to take a secure exam that limits the number of questions per page.

          I've tested this in Explorer 8 - and it does prompt for access to clipboard once the student clicks on "continue" to begin his/her attempt. But if you say "allow access" to the IE8 clipboard prompt, you stay in the quiz. If you don't allow access, you are booted out of the quiz. If you clicked on allow access, take the first page of questions, and then click on "save without submitting" on the quiz - it does boot you back to the first page and doesn't save your answers. If instead you click "next" to access the next page of questions, there is no problem. Then you have to click on "submit all and finish" when done with the exam.

          Temporary fix instructions to users:

          Internet Explorer 8 (IE8) has a current incompatibility with quizzes delivered in secure mode with a limited number of questions per page on our system.

          If you are an IE 8 user, we describe below how you can currently work-around this bug.

          1. When you log in to take your quiz- immediately after you click on the "Continue" button to begin, if you are prompted to "Allow access to your clipboard", choose "Allow access".

          2. Take the first page of questions on the quiz. When you are ready to go to the next page of questions, click on the "Next" button. Again, choose "Allow access" when you are prompted by Internet Explorer 8 for access to your clipboard.

          3. Do this for each page of questions.

          4. When you are finished with the last page of questions, click on "Submit all and Finish" and click "ok" to close your quiz attempt.

          This will save your work.

          Do not at any time during the quiz click on "save without submitting" or you will lose your work and return to the first screen of the quiz or be booted out of the quiz.

          Mauno Korpelainen added a comment -

          I think I found the main problem for window.open difficulties - IE8 simply can't use any given names for popup target window name in IE8 mode

          Only _blank, _media, _parent, _search, _self and _top are accepted and if User Access Control in Vista is off security model of IE8 blocks even _blank.

          A working solution seems to be using empty name '' instead of some given name like 'chat66' for pop-up target window - IE8 uses default value for target window and opens popup - and all other browsers that I tested seemed to work as well.

          Mauno Korpelainen added a comment -

          function link_to_popup_window ($url, $name=null, $linkname=null,$height=400, $width=500, $title=null,$options=null, $return=false) is referenced about 50 times in moodle so there may be quite many of those tags that should be checked as well... if we want to use IE8 in IE8 mode

          Mauno Korpelainen added a comment -

          See also http://msdn.microsoft.com/en-us/library/ms534659(VS.85).aspx

          and

          http://msdn.microsoft.com/en-us/library/ms537634(VS.85).aspx

          As of Windows Internet Explorer 8, dynamic properties have been deprecated and are only supported for Web pages displayed in IE5 mode or IE7 mode.

          Mauno Korpelainen added a comment -

          I may be wrong again but after revisiting http://tracker.moodle.org/browse/MDL-19113 IE8 looks even stranger than before. It has been reported before that name of target window may not contain spaces but in chat popup a target name like 'chat66' worked and similar name created by php tags "chat$course->id$chat->id$groupparam" did throw an error.

          Maybe I'll leave investigating of IE8 mode to others and just use IE8 in compatibility view if needed like before... while waiting for IE9... http://blogs.msdn.com/ie/archive/2009/11/18/an-early-look-at-ie9-for-developers.aspx

          Dan Poltawski added a comment -

          Hi,

          I am afraid we are no longer supporting 1.x branches and I am not aware of any remaining issues in 2.x so i'm closing this issue.


            People

            • Votes:
              2 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: