Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-18762

Activity report default tab should be "Today's logs"

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.6, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.6.8, 1.6.9, 1.6.9+, 1.7, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.7, 1.7.7+, 1.8, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.8.7, 1.8.8, 1.8.9, 1.9, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 2.0
    • Fix Version/s: None
    • Component/s: Performance, Usability
    • Labels:
      None
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE, MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      As an admin, I often want to see what a particular user is doing on the site. The outline report is not as useful to me as the "Today's Logs" or "All Logs". Also the Outline Report takes a long time to load for many of our users. I think that the "Today's Logs" tab should be the default tab in the Activity Report area. It is more usable for admins and it is a lighter load on the server.

        Gliffy Diagrams

        1. tabs.php
          14 kB
          Chetan Bansal
        2. user-tabs-patch.txt
          0.7 kB
          Jose Cedeno

          Issue Links

            Activity

            chetan.bansal Chetan Bansal added a comment -

            We have to edit line 238 in moodle\user\tabs.php

            from

            $toprow[] = new tabobject('reports', $CFG->wwwroot.'/course/user.php?id='.$course->id.
            '&user='.$user->id.'&mode=outline', get_string('activityreports'));

            to

            $toprow[] = new tabobject('reports', $CFG->wwwroot.'/course/user.php?id='.$course->id.
            '&user='.$user->id.'&mode=todaylogs', get_string('activityreports'));

            to change the default report displalyed.

            -Chetan

            floppyears Jose Cedeno added a comment -

            Made the user provided fix into a patch.

            floppyears Jose Cedeno added a comment -

            I totally agree with the Chetan, the Today's log makes more sense. See patch file.

            nikhilmishra Nikhil added a comment -

            Agreed with the views of friends, But rather than changing default tab ,

            We should give admin option of selecting and configuring the tabs he want

            Because there might other admin who might want some other tab.

            Open for comments

            poltawski Dan Poltawski added a comment -

            Hi,

            I'm closing this as from my reading of the issue its not relevant on 2.x. 'Todays logs' is the top report in activity reports and ther eisn't really a default.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: