Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-18083 META: Gradebook improvements - Stage 1
  3. MDL-19014

multiplicator and offset are used only for activity grades - must be disabled elsewhere

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.9.4
    • Fix Version/s: 1.9.5
    • Component/s: Gradebook
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Gliffy Diagrams

        Issue Links

          Activity

          skodak Petr Skoda added a comment -

          fixed

          ganderson Gary Anderson added a comment -

          While I don't think we have ever used this feature in any of our classes, it is not evident to me why activities and manually entered items would be treated differently.

          My understanding is that "offset", for example, would be used by an instructor who decides to add a few points to a test after she determines that a certain question is ambiguous. But this is just as likely to happen if the item was done offline as online. The same might go for multiplier if the teacher is using it as a method of scaling.

          Looking at the original bug, I also don't understand why this scaling or transformation would not apply to overridden grades based on my perception of why this feature is made available.

          As this may cause confusion, it might be helpful to discuss why it is available to only non-overridden activities.

          --Gary

          skodak Petr Skoda added a comment -

          Offset and multiplication factor are intended only for grade coming from activities (aka raw grades). We have decided long ago that it does not make much sense to have it for other types of grades - like calculated, aggregated and manual.

          I did not change anything this was just a regression in the new ui.

          nicolasconnault Nicolas Connault added a comment -

          Verified. Thanks Petr.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                13/May/09