Moodle
  1. Moodle
  2. MDL-19069

Remote RSS Feeds breadcrumb navigation broken

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.9.4, 2.1.7, 2.2.4, 2.4
    • Fix Version/s: 2.3.5, 2.4.2
    • Component/s: Blocks, RSS
    • Testing Instructions:

      As Admin:

      1. Access a course
      2. Add a Remote RSS Feed block
      3. Configure it.
      4. Click "Add/edit feeds"
      5. Click "Add a new feed"
      6. Enter a valid RSS feed URL and click "Add a new feed"
      7. Breadcrumbs now read: Home > thecourse > Blocks > Remote RSS Feeds > Manage all my feeds.

      Make sure the breadcrumbs for 'Remote RSS feeds' is not a link and 'Manage all my feeds' is a link.

      Redo the above testing as teacher.

      Show
      As Admin: Access a course Add a Remote RSS Feed block Configure it. Click "Add/edit feeds" Click "Add a new feed" Enter a valid RSS feed URL and click "Add a new feed" Breadcrumbs now read: Home > thecourse > Blocks > Remote RSS Feeds > Manage all my feeds. Make sure the breadcrumbs for 'Remote RSS feeds' is not a link and 'Manage all my feeds' is a link. Redo the above testing as teacher.
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull from Repository:
    • Pull 2.4 Branch:
      MDL-19069_m24
    • Pull Master Branch:
    • Rank:
      5242

      Description

      When editing an RSS feed displayed with the Remote RSS Feeds block, the breadcrumb navigation of the course is replaced with a breadcrumb trail starting with Administration / Modules. There is no way to navigate back to the course area without going to the Moodle front page first. Whether the feed is shared or not does not affect this behaviour.

      Steps to reproduce:

      1. Add a Remote RSS Feeds block to a course.
      2. Edit it.
      3. Select the Manage all my feeds tab.
      4. Add a feed, if you have none.
      5. Edit an existing feed.

      Instead of showing the name of the course area, the breadcrumb navigation changes into the following:

      • moodle
      • / ? Administration
      • / ? Modules
      • / ? Blocks
      • / ? Remote RSS Feeds
      • / ? Add New

      6. Even after editing, the user stays in that screen, and there is no way to navigate back to the course area short of returning to the front page of the Moodle installation.

      1. Add-Edit Feeds.png
        91 kB
      2. error1.png
        2 kB
      3. error2.png
        2 kB

        Activity

        Steve Bond added a comment -

        Error messages described in Steve Bond's 16 Aug 2011 comment.

        Steve Bond added a comment -

        This is still broken, although in a different way, in Moodle 2.1.

        To reproduce, as Teacher:
        1. Create a Remote RSS Feed block
        2. Edit it.
        3. Click "Add/edit feeds"
        4. Click "Add a new feed"
        5. Enter a valid RSS feed URL and click "Add a new feed"
        6. Breadcrumbs now read: Home > My courses > STB > Blocks > Remote RSS Feeds > Manage all my feeds. Click on Remote RSS Feeds.
        7. You now see an error "Section error" (see attachment error1.png).
        8. Click Continue - you get another error "Sorry, but you do not currently have permissions to do that (Change site configuration)", as shown in attachment error2.png
        9. Click Continue and you are taken to the Moodle front page.

        The cause of the problem seems to be that the "Remote RSS Feeds" link in the breadcrumbs in step 6 is pointing the page Moodle > Site administration > Plugins > Blocks > RSS client, which is not available to Teachers.

        Steve Bond added a comment -

        Could someone update this as being an open bug for 2.1 (and 2.2), or should I submit a new issue?

        Heikki Wilenius added a comment -

        I added the latest 2.1 and 2.2 versions to the "affects versions" field.

        Ray Lawrence added a comment -

        Adding 2.4 as affected version.

        Rossiani Wijaya added a comment -

        Creating patch to remove the breadcrumbs link for 'Remote RSS feeds' to make it consistent with the rest of block editing page.

        Ankit Agarwal added a comment -

        Hi Rosie,
        The patch looks great.

        [y] Syntax
        [y] Output
        [y] Whitespace
        [-] Language
        [-] Databases
        [y] Testing
        [-] Security
        [-] Documentation
        [y] Git
        [y] Sanity check

        Feel free to send it for integration.
        Thanks

        Rossiani Wijaya added a comment -

        Thanks Ankit for reviewing.

        Sending for integration review.

        Eloy Lafuente (stronk7) added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        Sam Hemelryk added a comment -

        Thanks Rosie, this has been integrated now.

        David Monllaó added a comment -

        Tested in 23 and master, it passes

        Eloy Lafuente (stronk7) added a comment -

        A brilliant future is awaiting us out there, better with your code. Let's look towards the future together, this is now closed.

        (and won't be revisiting it unless some regression is found)

        Thanks and ciao


          People

          • Votes:
            7 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: