Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-1912

wrong paging when browsing Not categorised

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4
    • Fix Version/s: None
    • Component/s: Glossary
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_14_STABLE

      Description

      I have a glossary with two pages worth of entries. When I browse by category and then choose Not categorised it shows the paging bar, even when there is only one entry. If the entry is late in the alphabet it shows up on the second page and the first page has no entries.

        Gliffy Diagrams

          Attachments

            Activity

            dougiamas Martin Dougiamas added a comment -

            From Eloy Lafuente (stronk7 at moodle.org) Tuesday, 7 September 2004, 07:06 AM:

            Yeah,

            I saw it when I was testing MDL-1903. :-D Thanks!!

            It's going to be a bit more difficult because records are always retrieved (that's the cause of the paging being showed) and then they are skipped at iteration time...

            Some day, when Moodle's DB requirements go up, we'll can use boolean operators and sub-queries. This will do things really easier for us!!

            Ciao

            From Eloy Lafuente (stronk7 at moodle.org) Friday, 10 September 2004, 02:34 AM:

            Done!! It was really complex!!

            Important changes about how view.php (and print.php) retrieve records

            from BD to be displayed. Some SQL statements have been modified to

            get target records, avoiding a lot of post-processing causing this and OTHER similar bugs.

            Should work in postgresql too (not tested). I'll close this in some hours...ciao

            From Martin Dougiamas (martin at moodle.com) Saturday, 11 September 2004, 09:27 PM:

            Thanks, Eloy. I'm going to assume it's working ... it will be in 1.4.1.

            mblake Michael Blake added a comment -

            assign to a valid user


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: