Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-19334

Relative links in uploaded HTML files break with slasharguments OFF

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.9.2, 1.9.3, 1.9.4, 1.9.5
    • Fix Version/s: None
    • Component/s: Resource
    • Labels:
      None
    • Environment:
      Tested on 1.9.3 on LAMP and 1.9.5 on LAMP; also reported on 1.9.2
    • Database:
      Any
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      When uploading a HTML file with relative links in it and server slasharguments set to OFF, the links are written as <WWWROOT>/<LINK> instead of <WWWROOT>/file.php/<FOLDER><LINK> This then breaks the links in the uploaded HTML file as a 404 error is given. You can read more about it in these two posts on the forums: http://moodle.org/mod/forum/discuss.php?d=123984 and http://moodle.org/mod/forum/discuss.php?d=123578

      I have attached an example of two html files that exhibit this behaviour with slash arguments off.

        Attachments

          Activity

            People

            Assignee:
            skodak Petr Skoda
            Reporter:
            jonwitts Jon Witts
            Tester:
            Nobody
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: