Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-19398

New blocks editing user interface

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Blocks
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      See http://docs.moodle.org/en/Development:Very_flexible_block_system_proposal#User_interface for some very rough notes.

      A more detailed plan will emerge as I create subtasks for this issue.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              timhunt Tim Hunt added a comment -

              All subtasks done. Resolving.

              marina Marina Glancy added a comment -

              Hi Tim Hunt, there is still todo in the code:

              blocks/moodleblock.class.php:        $bc->annotation = ''; // TODO MDL-19398 need to work out what to say here.
              

              (discovered in MDL-47779)

              marina Marina Glancy added a comment -

              Please note that all issues that are closed as resolved or won't fix but still have remaining TODO or @todo in core are linked to MDL-47779 as "causing regressions"

              The link will be removed when all TODOs are removed (under another issue)

              timhunt Tim Hunt added a comment -

              Marina Glancy as far as I can see, looking through git history, and the fact that that comment has been there since 2.0 without anyone actually experiencing a problem, I think the right fix is to just delete that comment. If you think fixing this is important, please make a patch. I have more important things to do.

              marina Marina Glancy added a comment -

              me too, especially considering that this issue is one of many. I just moved them under one epic


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    24/Nov/10