Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-19433

clone on _SESSION in auth/mnet/auth.php is not php 5.2 safe.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.9.6, 2.0
    • Fix Version/s: None
    • Component/s: MNet
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      I replaced all clone() with fullclone() on my local site and this fixed the probem. Not sure if this is the correct solution.

      This should definitely be fixed in 2.0 with the php 5.2 requirement, and probably also 1.9 for those of us using 1.9 on php5.2

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: