Moodle
  1. Moodle
  2. MDL-19697

mnet users might never have firstaccess set

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.5, 2.0
    • Fix Version/s: 1.9.8, 2.0
    • Component/s: MNet
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      I'm not quite sure what this field means , if it's supposed to be the first time the user actually uses moodle, or their account creation time.

      At any rate, I have a bunch of mnet users (who have clicked around moodle) who have this set to 0.

      I guess the solution is to make auth/mnet/auth.php set it when the user first lands, since if they're landing, they're accessing the site. However, a more robust fix might be to make something like user_accesstime_log check it and set it if it's not set.

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Eloy Lafuente (stronk7) added a comment -

            Done, now the mnet auth plugin sets user->firstaccess before creation (insert) and also if empty when updating.

            Ciao

            Show
            Eloy Lafuente (stronk7) added a comment - Done, now the mnet auth plugin sets user->firstaccess before creation (insert) and also if empty when updating. Ciao
            Hide
            Helen Foster added a comment -

            Great work Sol, I'm going to test things as soon as coolcourses.moodle.org or dev.moodle.org get updated

            Show
            Helen Foster added a comment - Great work Sol, I'm going to test things as soon as coolcourses.moodle.org or dev.moodle.org get updated

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: