Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-19869

Separate Group shows : No users were found with permissions to submit this assignment even there are members in the group

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Won't Fix
    • Affects Version/s: 1.9.5, 2.0
    • Fix Version/s: None
    • Component/s: Groups
    • Environment:
      Linux

      Description

      1.Create a course.
      2.Create a separate group for the course from left side menu. Assign Students to the group.
      3. Create an Assignment from Activity Menu.
      4.Sign in as a Student who is a course group member.
      5.Submit an Assignment.
      6.Login as Faculty.
      7.Go to the Assignment.
      8.It show "No users were found with permissions to submit this assignment" for the particular group selected from drop box.
      9.But it shows 1 submission for All Participants.
      10. It should show submission for the separate group as the student is group member.

        Gliffy Diagrams

          Activity

          oksana Oksana Yasynska added a comment -

          I think it's related to functions groups_get_activity_group() && groups_get_course_group() in lib/grouplib.php

          .... but I'm not quite sure.
          If I find a solution - I'll post a patch

          vcastilho Valter Castilho added a comment -

          Hello,
          i've changed the lib/grouplib.php back to v1.9.0 beta (2006 version that selecting assignment submitions for one group worked) and the same bug remains in v1.9.5+ (today).

          mudrd8mz David Mudrak added a comment -

          Assigning to myself. Questions:
          1. is the "Faculty" user from the issue description member of the separate group?
          2. has the "Faculty" user capability accessallgroups?

          skodak Petr Skoda added a comment -

          lowering priority

          vrrandall Vernellia Randall added a comment -

          I just had the same problem. It is a significant issue. Is a work-around to use visible instead of separate groups or does the same problem present in visible group. I have not been an assignment of the groups - but the problem has not been the faculty members inability to see the groups but the students inability. Consequently, students in discussion forums are unable to post because they keep getting the message that they are not members of the group when in fact they are.

          mudrd8mz David Mudrak added a comment -

          The issue with separated groups in forum has been documented in wiki. That one is not bug - you just have to create a thread for each of the separated groups.

          Can somebody confirm this is still reproducible and answer my questions above? Sorry, not enough time to test it on my own right now. Thanks.

          hoyer801 Rory McDaniel added a comment -

          I have this same issue with 2.0 RC4. This issue did not exist for me in 1.9.7. It only appeared after upgrading to 2.0.

          drex Mark Drechsler added a comment -

          Just hit this in the daily build of 2.0 - any fix on the cards?

          tlock Tim Lock added a comment -

          In 2.0, as an admin these patches make this error go away - MDL-24245 & MDL-24246. As a teacher, the wording needs to be changed to something like "No assignment submissions have been received yet"

          drex Mark Drechsler added a comment -

          Tim & Co.

          Problem isn't with the error message - its that a teacher can't manually grade assignments if nothing has been submitted, something that does happen and that IMOP still needs to happen. Changing the error message isn't a fix.

          Mark.

          tlock Tim Lock added a comment -

          This patch is based off 2.0 RC1 (Build: 20100926) to show the Optional settings for the Assignment page

          tlock Tim Lock added a comment -

          In Moodle 2.0, being able to change from Show Submitted only or Show All, etc (Optional settings) wasn't show if no users had submitted any assignment. Example being an off-line assignment will never have an assignments submitted.

          drex Mark Drechsler added a comment -

          Just discovered another use case which justifies a quick fix for this, namely the use of an Offline Assignment. Since students can never submit anything to an offline assignment you can't avoid hitting this error, so until its fixed the Offline Assignment is effectively useless from what I've seen and tried.

          Thanks Tim for the fix

          ashleyholman Ashley Holman added a comment -

          This also effects 2.0.

          khammond@iste.org Kim Hammond added a comment -

          Having the same trouble. I even combined my groups and removed the groups. It doesn't seem to be making a difference.

          gradyw Wayne added a comment -

          This is occuring in a subject which has no groups. The server is currently on 2.0.2+ and running on a WAMP environment. The same message showed up for a teacher after she marked several assignment and graded them. Suddenly part way through the process the screen showed the message "No users were found with permissions to submit this assignment".

          hoyer801 Rory McDaniel added a comment -

          This happens for me on 2.0.2+ as well. I think I was able to narrow it down a little bit more.

          In the Optional settings box at the bottom of the view submissions page is a filter that allows you to choose between viewing all students, only students that have submitted the assignment, and only students that require grading. If the preference is set to require grading but there are no students that need to be graded, you see the "No users were found with permissions to submit this assignment" message. My login is both the admin and the teacher for this course.

          The workaround is to go to an assignment that does have submissions that require grading and then change the settings back to All or Submitted.

          The problem is that when we see this message, there is no option to change the settings to view all or view submitted. The error should definitely say something to the effect of "no submissions require grading" and then still allow the teacher to change the filter setting.

          cfollin Chris Follin added a comment -

          We're having the same problem as Rory. Once you set the preference to show only submissions that require grading and there are none, you can't change it back unless you go to another assignment.

          gheredia Gustavo Heredia added a comment -

          We´re have the same problem as Rory and Chris. There is another way to view Optional settings box without going another assignment ? Thanks in advance

          mudrd8mz David Mudrak added a comment -

          Sorry I am currently unable to work on this personally, increasing the priority and re-assigning to moodle.com to be hopefully picked up for some next sprint.

          tlock Tim Lock added a comment -

          Hi All,

          Found that when Quick Grades was enabled the Optional settings box lost formatting.

          tlock Tim Lock added a comment -

          Added github Moodle 2.0 diff

          tlock Tim Lock added a comment -

          Updated Pull 2.0 URL

          stronk7 Eloy Lafuente (stronk7) added a comment -

          U P S T R E A M I Z E D !

          Many thanks, this is now available in all the repos (git & cvs).

          Closing, ciao

          stronk7 Eloy Lafuente (stronk7) added a comment -

          Doh,

          somehow this issue was closed incorrectly when processing all the integrated issues this week. (sort of most voted and current in integration filters mix). Apologies for the confusion, reseting to previous status!

          Ciao, Eloy

          marina Marina Glancy added a comment -

          I don't see any activity (and votes) on this issue for the last two years. It looks like it was fixed, probably by re-writing mod_assignment as mod_assign. Can anybody confirm please or claim that this can still be reproduced on currently supported moodle versions?

          marina Marina Glancy added a comment -

          Closing this issue as it does not affect supported versions and mod_assign


            People

            • Votes:
              20 Vote for this issue
              Watchers:
              15 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: