Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-19900

Tooltip text for grader report cells includes HTML

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.9.5, 1.9.6, 2.0
    • Fix Version/s: None
    • Component/s: Gradebook
    • Labels:
    • Database:
      Any
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      Here is an example of the HTML for a cell in the grader report. It's actually including HTML in the tool tip that appears when you hover over the cell:

      <td title='<div class="fullname">B***** B******</div><div class="itemname">Informative Speech</div><div class="feedback">I cannot get your CD to work. I<br/ >have tried in 2 DVD players, my<br/ >computer, and my sony camera. Did<br/ >you finalize it.</div>' class="grade cell c1"><span class="gradevalue">0.00</span></td>

        Gliffy Diagrams

          Attachments

            Activity

            jfilip Justin Filip created issue -
            jfilip Justin Filip added a comment -

            This is a patch against the latest version of /grade/report/grader/lib.php from the MOODLE_19_STABLE branch and it removes the HTML tags from the tool tip text used in the report cell HTML. There are also some whitespace fixes as my editor is configured to strip whitespace on save.

            jfilip Justin Filip made changes -
            Field Original Value New Value
            Attachment lib.php.patch [ 17953 ]
            jfilip Justin Filip added a comment -

            Added a screenshot showing the problem this patch fixes.

            jfilip Justin Filip made changes -
            Attachment GradeBook2.png.jpg [ 17985 ]
            emerrill Eric Merrill added a comment -

            I've attached a cleaner patch - the previous one had some changes that were not pertinent to the bug.

            I've also added a - between the user name and the grade item name.

            I need to research the code some more to make sure that this doesn't affect anything, but if not, and if there are no objections, I'll commit this in the next few days.

            -eric

            emerrill Eric Merrill made changes -
            Attachment gradetooltip.diff [ 18805 ]
            emerrill Eric Merrill made changes -
            Fix Version/s 1.9.7 [ 10360 ]
            Affects Version/s 1.9.6 [ 10340 ]
            stronk7 Eloy Lafuente (stronk7) made changes -
            Fix Version/s 1.9.8 [ 10400 ]
            Fix Version/s 1.9.7 [ 10360 ]
            skodak Petr Skoda made changes -
            Assignee Petr Skoda [ skodak ] moodle.com [ moodle.com ]
            tsala Helen Foster added a comment -

            Just noting that this issue has also been reported in the gradebook forum: http://moodle.org/mod/forum/discuss.php?d=141908

            ccordeiro Cristian Cordeiro added a comment -

            Although this is reported as pertinent to versions 1.9.5 & 1.9.6, it also happens on version 2.0, so I wonder if Eric's fix was not yet committed or if it was committed but it is just not merged into 2.0 yet. I've made a patch for version 2.0 and I would be happy to contribute, just wanted to understand if it is something that was already taken care of or if it is something that I could be contributing on.

            Cristian Cordeiro

            dougiamas Martin Dougiamas made changes -
            Fix Version/s 1.9.9 [ 10405 ]
            Fix Version/s 1.9.8 [ 10400 ]
            dougiamas Martin Dougiamas made changes -
            Fix Version/s 1.9.10 [ 10407 ]
            Fix Version/s 1.9.9 [ 10405 ]
            dougiamas Martin Dougiamas made changes -
            Fix Version/s 1.9.11 [ 10410 ]
            Fix Version/s 1.9.10 [ 10407 ]
            dougiamas Martin Dougiamas made changes -
            Workflow jira [ 32840 ] MDL Workflow [ 45206 ]
            dougiamas Martin Dougiamas made changes -
            Fix Version/s 1.9.12 [ 10536 ]
            Fix Version/s 1.9.11 [ 10410 ]
            tsala Helen Foster added a comment -

            Thanks for all the patches and apologies for this issue having been neglected for so long. Can anyone confirm that the problem also affects the latest 2.0.2?

            tsala Helen Foster made changes -
            Labels patch triaged
            Assignee moodle.com [ moodle.com ] Andrew Davis [ andyjdavis ]
            Fix Version/s STABLE backlog [ 10463 ]
            Fix Version/s 1.9.12 [ 10536 ]
            Affects Version/s 2.0 [ 10122 ]
            dougiamas Martin Dougiamas made changes -
            Workflow MDL Workflow [ 45206 ] MDL Full Workflow [ 73557 ]
            moodle.com moodle.com made changes -
            Fix Version/s STABLE Sprint 11 [ 10751 ]
            Fix Version/s STABLE backlog [ 10463 ]
            andyjdavis Andrew Davis made changes -
            Status Open [ 1 ] Development in progress [ 3 ]
            andyjdavis Andrew Davis added a comment - - edited

            Hi. I'm not able to reproduce this against current 1.9.12, 2.0.3 or 2.1.0. I've also turned up this previously fixed issue, MDL-20179, so I believe this has already been fixed.

            Thankyou for the bug report

            andyjdavis Andrew Davis made changes -
            Status Development in progress [ 3 ] Closed [ 6 ]
            Resolution Duplicate [ 3 ]
            stronk7 Eloy Lafuente (stronk7) made changes -
            Fix Version/s STABLE Sprint 11 [ 10751 ]

              People

              • Votes:
                5 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: