Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.4.2, 2.0, 2.6
    • Fix Version/s: DEV backlog, FRONTEND
    • Component/s: Forum
    • Labels:
    • Environment:
      All
    • Database:
      Any
    • Affected Branches:
      MOODLE_14_STABLE, MOODLE_20_STABLE, MOODLE_26_STABLE

      Description

      Sticky comments that are available in most other discussion boards might be a good addition. Useful for posting forum rules or descriptions e.g. in the discussion boards for moodle I often go in to a forum for say SCORM or Book and would like to see a sticky at the top of the forum explaining what the module is and what the forum is for.

        Gliffy Diagrams

          Issue Links

            Activity

            lael Lael... added a comment -

            I know this feature request has been sidelined for a long time, but I think it is something that many people would benefit from. There are work-arounds (linking to discussion in summary section), but sticky posts seem to be more intuitive and effective.

            my 2c

            Lael

            dougiamas Martin Dougiamas added a comment -

            Assigning to me temporarily because Vy-Shane no longer works for Moodle HQ.

            hinkelman Don Hinkelman added a comment -

            From the "How to vs. Forum" discussion in Using Moodle:

            Marc: "SO I guess I have to vote "Aye" for sticky topics..."

            Don: My vote goes strongly for sticky topics as well. Sorry, Helen, I lost this thread when it was split. Five weeks later, I hope someone is still watching.

            The sticky topic option would offer many advantages:

            • preserve forums without pruning
            • key points in the thread would be easily viewable at the top of the thread
            • a moderator role could transform an ordinary thread into a sticky thread if it proves more valuable or popular.
            • links to Moodle docs or other references could be added at any time to the master post at the top

            Operation: I would make this semi-automatic for a moderator role.

            1. Moderator highlights a section of text
            2. Click a button to "transform to sticky topic"
            3. The highlighted text is changed into a "sticky" post at the top of the thread. It remains there throughout the life of the topic.
            4. The "sticky" post can be edited manually and linked to Moodle docs or other wikis, FAQs and references
            5. The whole thread also becomes "sticky" in that it remains on the top of the forum list, even if there are no new posts.

            net-buoy Marc Grober added a comment -

            Part and parcel of the latest bit of discussion in the forums was (in addition to the variety of ways in which distillation could be accomplsihed) the suggestion that Moodle switch to a php forum that already included such functionality. While I do agree that forums are very valuable, I don;t see why "modular" can't mean using someone else's "module" for core functions..... I am not suggesting that Moodle simply drom moodle forum and integrate phpbb..... but it would be nice to see perhaps an analysis matrix examining some open software out there and pros vs cons of integrating that vs rewriting moodle (including benefits and detriments of moodlers taking an active role in discussing dev of those of other products.....)

            hinkelman Don Hinkelman added a comment -

            Integration of a totally different open source script into Moodle is outside the scope of this feature request. Please continue discussion of this point on the forums, and if sufficient consensus is reached, make a new feature request. This request is strictly limited to adding "sticky" functionality to the current Moodle forum system.

            net-buoy Marc Grober added a comment -

            My error.
            I have posted a new tracker issue http://tracker.moodle.org/browse/MDL-14993 which is diametrically opposed to this tracker item

            cethrid Buddy Ethridge added a comment -

            This is a feature that I would very much like to see included in Moodle forums. The forums work very well now, but this function would greatly increase the usability.

            ralfh Ralf Hilgenstock added a comment -

            May be this is a nice new feature for Moodle 2.1 or 2.2.

            tsala Helen Foster added a comment -

            Setting a fix version of DEV backlog so the feature is considered for inclusion in 2.1.

            cfulton Charles Fulton added a comment -

            This sounds like a duplicate of MDL-372, though perhaps not if it has a greater proposed scope.

            dobedobedoh Andrew Nicols added a comment -

            Closing this issue as it is a duplicate of MDL-372 which has code submitted


              People

              • Votes:
                13 Vote for this issue
                Watchers:
                18 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: