Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-20061

get_fast_modinfo freezes MyMoodle

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Won't Fix
    • Affects Version/s: 1.9.5, 1.9.6
    • Fix Version/s: None
    • Component/s: Dashboard (My home)
    • Labels:
      None
    • Environment:
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      The problem has appeared after a migration from a Moodle 1.9.2+ installation (with 150+ courses and 2800+ users) to a Moodle 1.9.5+ (build 20090805).
      The default main screen works perfectly but when I force one user login to MyMoodle the platform freezes with Apache at 100% CPU load, for more than 8 minutes.
      In the Moodle 1.9.2+ installation MyMoodle never took more than 8s (showing more than 100 courses).

      The problem, I think, is in get_fast_modinfo() function, but I could not even find... any idea ? (sorry for my English).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              moodle.com moodle.com
              Reporter:
              rsambora Richie Sambora
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: