Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-20128

Can't install Moodle 1.8.9 with PHP 5.3

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 1.8.9
    • Fix Version/s: None
    • Component/s: General, Installation
    • Labels:
      None
    • Environment:
      XAMPP 1.7.2 for Mac OS X which comes with PHP 5.3.0
    • Affected Branches:
      MOODLE_18_STABLE

      Description

      I want to build Moodle4Mac with Moodle 1.8.9 (20090819) and the new XAMPP 1.7.2. It comes with PHP 5.3 so it should work with all Moodle versions. Where could be the problem?

        Gliffy Diagrams

          Activity

          Hide
          krause Ralf Krause added a comment -

          I get the same problem with Moodle 1.8.9+ (20090819) on my Mac OS X 10.5.8 Server and an installed Entropy PHP 5.3.0-3.pkg.
          For the server configuration please look at http://docs.moodle.org/en/Step_by_Step_Installation_on_a_Mac_OS_X_10.5_Server

          Show
          krause Ralf Krause added a comment - I get the same problem with Moodle 1.8.9+ (20090819) on my Mac OS X 10.5.8 Server and an installed Entropy PHP 5.3.0-3.pkg. For the server configuration please look at http://docs.moodle.org/en/Step_by_Step_Installation_on_a_Mac_OS_X_10.5_Server
          Hide
          krause Ralf Krause added a comment -

          I switched back to PHP 5.2.9 on the Mac OS X Server and Moodle 1.8.9+ (20090819) could be installed properly. But I can't switch back XAMPP 1.7.2 ... bad thing!

          Show
          krause Ralf Krause added a comment - I switched back to PHP 5.2.9 on the Mac OS X Server and Moodle 1.8.9+ (20090819) could be installed properly. But I can't switch back XAMPP 1.7.2 ... bad thing!
          Hide
          skodak Petr Skoda added a comment -

          unfortunately PHP 5.3.0 removes some more PHP 4.x compatibility, I hope we have solved all the PHP 5.3 issues in 1.9.6

          I am afraid we do not have resources to support 1.8.x under PHP 5.3, sorry

          Show
          skodak Petr Skoda added a comment - unfortunately PHP 5.3.0 removes some more PHP 4.x compatibility, I hope we have solved all the PHP 5.3 issues in 1.9.6 I am afraid we do not have resources to support 1.8.x under PHP 5.3, sorry

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: