Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-20210

DB auth plugin ends with own print_error() if no matching l/p (or l only for internal) is found

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.7, 1.8.9, 1.9.5
    • Fix Version/s: 1.9.10
    • Component/s: Authentication
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      Uhm...

      was asking to Howard at: http://moodle.org/mod/forum/discuss.php?d=131784 and, when looking at the db/auth.php plugin... I've detected that it has one (two in fact) ANNOYING print_error() if the login/password check fails.

      Other auth plugins haven't that at all. Expected behaviour is to return true/false only (without own printing and die) afaik. Can you imagine any reason for that? Seems that it's there since the beginning.

        Gliffy Diagrams

          Attachments

            Activity

            iarenaza Iñaki Arenaza added a comment -

            IMHO, there's no reason at all. In fact, the error message is wrong: it's not that we couldn't connect, it's that we didn't find the user and/or the password was wrong.

            So +1 to remove the print_error() calls.

            Saludos,
            Iñaki

            skodak Petr Skoda added a comment -

            1.7x is not supported any more, which print_error()s did you mean exactly?

            skodak Petr Skoda added a comment -

            Fixed, thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Oct/10