Moodle
  1. Moodle
  2. MDL-17284 Add Olli's new quiz editing UI to Moodle 2.0
  3. MDL-20263

Inform users of questions having been added to also question bank when using 'Add question' button

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Quiz
    • Labels:
      None
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      26232

      Description

      There are two ways of seeing what adding a question in a quiz means. The first one is the one proposed by the original data structures: questions are created in the question bank and then added to a quiz. The second one is the new model: you add a question directly into a quiz, and as a convenient service from the system, the question also gets added to the question bank for later use. This became as clear as it is now to me only when talking with Ray Lawrence in MMUK09.

      All the implications of either of the ways to understand it should be supported.

      When adding a question using the 'Add question' button, there should be explicit feedback to the user, informing them about this: "Your question was added to the quiz. In addition, a copy of it has been placed in the question bank, in the category X, to facilitate later use". This is the only way for users to learn this happens (except by accident).

      I always forget, if this is also reflected in how editing questions in the question bank or in the quiz works - if you edit one, does it change the other?

      Wondering about the paradigmatic change that the new Quiz editing UI introduced (still for my thesis), I found that I've been not practicing what I preach in the above. Alas, this issue.

        Activity

        Olli Savolainen created issue -
        Tim Hunt added a comment -

        In other places, for example if you add or edit a question in the question bank, the last edited question gets highlighted there.

        I have added the same thing for when you create and add a question directly to the quiz. It is then displayed highlighted in the question bank. I think that is a simple and elegant way to solve this.

        Tim Hunt made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Olli Savolainen added a comment -

        Great stuff that you got this done. Looks good.

        I am only learning that to get email notifications, you have to "watch" an issue. Sometimes it seems though that I get notifications even if I don't "watch" them first.

        Tim Hunt added a comment -

        You get email if you watch it, reported it, are QA assignee, or have it assigned to you.

        Olli Savolainen added a comment -

        Yeah, that's what I thought too but for me there seems to be some sort of a mystical algorithm present and watching the ticket at least increases the odds of the email actually arriving. I haven't found anything in my spam account either. Oh well.

        Elena Ivanova added a comment -

        I would also suggest to rename the button in the Quiz from "Add a question" into "Create and add a question"
        Just looking on this form another angle: "Add a question" phrase can possibly imply that you would be now adding an already existing question, not creating a new one.

        Olli Savolainen added a comment -

        Thanks Elena! The issue is that there are two conceptual models present: for novices who do not use the question bank, nothing else is thinkable than that "adding" a question also creates it. So your suggestion would complicate things in that scenario.

        I believe that at worst, it is a one-time error for even experienced users, so the compromise seems less dangerous in the current UI than it would be if "Create and..." would be added. However, I would love to get some usability testing results that indicate this being a source of confusion for users who do use the question bank - please do report here if you get a chance to witness that.

        Martin Dougiamas made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        QA Assignee nobody
        Martin Dougiamas made changes -
        Workflow jira [ 33338 ] MDL Workflow [ 58498 ]
        Martin Dougiamas made changes -
        Workflow MDL Workflow [ 58498 ] MDL Full Workflow [ 92302 ]

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: