Moodle
  1. Moodle
  2. MDL-2027

problem when restoring internal link with #

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4.1
    • Fix Version/s: None
    • Component/s: Backup
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_14_STABLE
    • Rank:
      10453

      Description

      In some resources we have link to come back to the course, with #n which indicates the bloc number :

      fictive example :

      http://www.sante-pub.u-nancy.fr/moodle/course/view.php?id=20#2

      When I backup this course and restore it in a other site, this sort of link is not transformed ( I suppose moodle consider it's a external link)

        Activity

        Martin Dougiamas added a comment -

        From Eloy Lafuente (stronk7 at moodle.org) Friday, 1 October 2004, 12:27 AM:

        Hi etienne,

        As you said, that type of links are considered external and the backup & restore process won't transform them automatically. More exactly, I think that the SITE part of them (http://www.sante-pub.u-nancy.fr/moodle) should be modified, but the COURSE VIEW part not.

        I'm going to see if it's possible to implement it but I'm not really sure, mainly because the number of potential links is practically unlimited (links course page, to modules, to use profiles...).

        Ciao

        From Etienne (etienne.roze at medecine.uhp-nancy.fr) Friday, 1 October 2004, 06:21 PM:

        >> More exactly, I think that the SITE part of them >>(http://www.sante-pub.u-nancy.fr/moodle) should be >> modified, but the COURSE VIEW part not.

        Sorry, but the SITE doesn't change anyway... And, I saw that the problem is the same for the links to the course page ( even without the #)

        An other thing (other bug ?): link to assigment do not change either... And links inside assigment to ressources stay in this form : http://www.sante-pub.u-nancy.fr/moodle/mod/assignment/$@RESOURCEVIEWBYID*216@$

        May be I have a problem of version of moodle : the two sites are in different version... (origin : Moodle 1.5 unstable development (2004083000) and target : Moodle 1.4.1+ (2004083110) )What do you think about it ?

        I will be happy to help by coding, but I am not sure to understand all the structure of a course in Moodle and the procedure to backup and restore courses. Does a document exist to initiate me ? I don't find it on moodle.org.

        From Eloy Lafuente (stronk7 at moodle.org) Friday, 1 October 2004, 07:16 PM:

        Hi etienne,

        you are right!! The SITE part is only modified in the process if it belongs to call to file.php. Some time ago, between 1.2 and 1.3 I made some tests about changing WWWROOT everywhere but finally I discard it. That was the reason of my mistake. Sorry.

        About your required links from assignments to resources, it's easy to implement. I think I'll do it today. Currently, only links between resources and forums are preserved, mainly because they are rarely used and you can use the activity names filter to let's Moodle show that links automatically.

        Ciao

        From Eloy Lafuente (stronk7 at moodle.org) Friday, 1 October 2004, 07:35 PM:

        Done in CVS. Now resource links are transformed in assignment->description too!

        From Etienne (etienne.roze at medecine.uhp-nancy.fr) Friday, 1 October 2004, 08:38 PM:

        Thank you very much and really cheer!!! You are fastest... Which are the files which changed? Only those under the repertory backup or other modules specific files ?

        From Eloy Lafuente (stronk7 at moodle.org) Saturday, 2 October 2004, 12:31 AM:

        mod/resource/restorelib.php

        Anyway it will be available in 1.4.2 (just coming...)

        Ciao

        From Eloy Lafuente (stronk7 at moodle.org) Sunday, 10 October 2004, 09:39 AM:

        I'll close this now. Reopen if necessary.

        Michael Blake added a comment -

        assign to a valid user


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: