Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-20320

PDFs are not displaying according to settings

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.9.5
    • Fix Version/s: 1.9.6
    • Component/s: Resource
    • Labels:
      None
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      In 1.9 PDFs are not displaying according to the settings.

      See http://moodle.org/mod/forum/discuss.php?d=132906#p581622 for details.

      In short, here are combinations and expectations:

      1) Same window, navigation = No ..... PDF should be called directly and it isn't.
      2) Same window, navigation = Yes, with Frame ..... PDF should appear in lower frame and it isn't.
      3) Same window, navigation = Yes, without Frame .... PDF should appear embedded and it is (this is what happens for above two as well)

      Apparently all that is needed is to remove $embedded = true but I'm not sure if that's 100% correct on all browsers. Can you review this and fix it?

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Votes:
                  3 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    21/Oct/09