Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-20522

Something could be wrong in question/calculated upgrade script

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Questions
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Hi, was reviewing HEAD savepoints and found this:

      • /question/type/calculated/db/upgrade.php:
        + found 3 matching 'if' blocks and 'savepoint' calls
        + versions in upgrade blocks properly ordered
        + ERROR: version 2009082000 has wrong savepoint call with version 2009092000

      Also, next step has strange condition:

      if ($result && $oldversion >= 2009082000 && $oldversion < 2009092000 )

      So I'm not really sure how both things should be fixed... if you can take a look to it... TIA!

        Attachments

          Activity

            People

            Assignee:
            ppichet Pierre Pichet
            Reporter:
            stronk7 Eloy Lafuente (stronk7)
            Tester:
            Nobody
            Participants:
            Component watchers:
            Tim Hunt, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              24/Nov/10