Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28443 Action logging improvements META
  3. MDL-20733

When creating a new user, the log doesn't include the id of the newly created user

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.9.5
    • Fix Version/s: None
    • Component/s: Other
    • Labels:
      None
    • Environment:
      independent
    • Database:
      MySQL
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      When creating a new user, the log registered doesn't include the id of the newly created user,
      I suggest to use the Info field to store this information.
      In attach I provide a new version of the 'user/editadvanced.php' file that could offer this minor enhancement: it is based on the movement of the line

      add_to_log($course->id, 'user', 'update', "view.php?id=$user->id&course=$course->id", '');

      from line 80 to line 104 (with the use of the variable $usernew->id for memorizing the new user's id)

      add_to_log($course->id, 'user', 'update', "view.php?id=$user->id&course=$course->id", $usernew->id);

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              ankit_frenz Ankit Agarwal added a comment -

              This issue is a duplicate of MDL-28386, which will hopefully get integrated soon.
              Thanks


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: