Moodle
  1. Moodle
  2. MDL-20738

print_scale_menu_helpbutton() and help_button::make_scale_menu() are broken

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Libraries
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Currently in HEAD print_scale_menu_helpbutton() & help_button::make_scale_menu() are throwing exceptions.

      print_scale_menu_helpbutton() is in deprecated lib and is simply used as follows:
      $OUTPUT->help_button(help_button::make_scale_menu($courseid, $scale));

      2 immediate problems are

      • OUTPUT doesn't have a help_button method.... it should probably be help_icon
      • The help_button class doesn't exist... it should probably be moodle_help_icon

      However even after those have been corrected you still get mountains of exceptions because of different things not being set on the classes.
      I'm not 100% sure but in this case scale menu is a fringe case as it has a special help page (Am I thinking of the right thing here).
      I would imagine that the whole implementation of that needs to be re-thought.

      Also to whoever takes on this issue, grap for '::make_scale_menu' there are several implementation that need correcting.

        Gliffy Diagrams

          Issue Links

            Activity

            Simon Coggins added a comment -

            This seems to have been fixed by MDL-21217

            Dan Poltawski added a comment -

            Closing as duplicate of MDL-21217, thanks Simon


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: