Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.6
    • Fix Version/s: 1.9.7
    • Component/s: Workshop
    • Labels:
      None
    • Database:
      MySQL
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      31872

      Description

      When accessing Workshops as Teacher, views may differ without apparent reason. Different teacher/admins may obtain different views of the same workshop.

      Attached a sample of different views of different workshops, obtained by the same user: a view misses Assesment and Assesment grade column.

        Activity

        Petr Škoda added a comment -

        Please never set fix version to already released version This flag is usually set by developers when some fix is confirmed to be in some release, the reported should not usually use it even if he is allowed to do so.

        Andrea Bicciolo added a comment -

        Thanks Petr, I'll do

        David Mudrak added a comment -

        This is not bug. It happens to you because the workshop have different settings. The displayed columns are determined by the workshop type. The "parziale" screenshot represents a workshop type no grading grades. The "completo" screenshot is a workshop type with grading grades.

        The complete table is displayed if

        • "Self Assessment" is enabled or
        • "Number of Assessments of Examples from Teacher" is set to a non-zero value or
        • "Number of Assessments of Student Submissions" is set to a non-zero value.

        In the workshop with self assessment disabled, no teachers examples and no peer-grading, the shortened table without assessment information is displayed.

        Andrea Bicciolo added a comment -

        David, thank you for your suggestions. Unfortunately, the two workshop has exactly the same settings. Settings from the shortned table view workshop:

        Self assesment->Disabled
        Number of Assessments of Examples from Teacher->0
        Number of Assessments of Student Submissions->10

        According to your suggestions, using the above settings, the complete table should appear, but it only appears the shortened one. URL available if needed.

        Andrea Bicciolo added a comment -

        Sent a faulty workshop URL by Jabber. Hope to be mistaken.

        David Mudrak added a comment -

        Andrea, try to resave the Workshop settings form - just click "Update this Workshop" button and then save. It should help. You are right - the workshop type is not calculated properly on newly created workshops that were not modified.

        David Mudrak added a comment -

        Fixed in CVS. $wtype properly calculated for new instances, too.

        Andrew Davis added a comment -

        Fix verified against 1.9.7


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: