Moodle
  1. Moodle
  2. MDL-2084

Choice module has no save my choice for admin (sesskey issue?)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.4.1
    • Fix Version/s: None
    • Component/s: Choice
    • Labels:
      None
    • Environment:
      Linux
    • Rank:
      14045

      Description

      After doing a bug update to 14_STABLE via CVS on 2004-10-11 15:30, -6 GMT , the choice module broke. [Moodle 1.4.2 nearly (2004083121)]

      When admin is logged in there is no Save my Choice button on choice page, but message You have to log in before you can submit your choice even though bottom of page displays admin's logged in name and logout toggle. Logging in a a student or teacher displays the button.

      Trying to update the module results in A required parameter (sesskey) was missing for both teachers and admins. Continue results in a kick out to the home page.

      You can see behavior @ http://classes.lco-college.edu/moodle/mod/choice/view.php?id=813 with: user: teacher pwd: teachme

        Activity

        Martin Dougiamas added a comment -

        From Jeffrey Ames (ames at lco-college.edu) Thursday, 14 October 2004, 03:38 AM:

        The sesskey issue has been wittnessed when attempting to edit a Quiz also.

        It seems as if the error is effecting may subsystems as it is now reported in Bugs #2087 & 2088

        What file is responsible?

        Could code maintainers please fix this by returning the 14_STABLE branch to a stable condition?

        From Jeffrey Ames (ames at lco-college.edu) Thursday, 14 October 2004, 04:01 AM:

        This may be two diffrent issues.

        Bugs #2087 & 2088 report the (sesskey) issue is from clicking the Update this resource button. Editing with turn editing on works as expected. This is part of the behavior I'm seeing also.

        The second issue is the Save my choice button not availble as a system administrator. This may or my not be related to the sesskey, but does seem to be a result of checking permissions of the logged in user, and not making good decisions based on those results.

        From Martin Dougiamas (martin at moodle.com) Friday, 15 October 2004, 12:35 AM:

        Can you update again? It seems OK for me on the latest CVS ...

        From Jeffrey Ames (ames at lco-college.edu) Saturday, 16 October 2004, 02:07 AM:

        Updated again on 20041015 12:30 PM -6 GMT Moodle 1.4.2 nearly (2004083122)

        Sesskey issued was resolved so Update this resource button now works. Thank you.

        However - the Save my Choice button still does not appear for admins. The message You have to log in before you can submit your choice is presented ironically above the You are logged in as System Administrator (Logout) message.

        From Jeffrey Ames (ames at lco-college.edu) Friday, 22 October 2004, 01:16 AM:

        This may not be such a big issue, but here is some more observations and a workaround.

        The You have to log in... message appears for admins if there are not added as participant. Adding an admin as a student or teach does not immediatly show the button either.

        The admins must log out then log back in for the button to be displayed. Also removing the uses from the participants list does not make the button go away immediately. Refreshing the page doest help. As before, once the admin logs out and logs back in, the error message comes back and no button is shown.

        This would seem to indicate the issue is with checking the identifier (cookie) generated upon log in. If there is no match of (cookie + UserID + (student or teacher)) then error occurs.

        From Dan Marsden (dan at digitalclay.co.nz) Friday, 1 April 2005, 09:44 AM:

        the Save my Choice button not appearing seems to be expected behaviour - line 49 of mod\choice\view.php prevents admins from being given the button-

        isteacher($course->id, 0, false))

        • I can change this if it is really a bug, not just expected behaviour. - Martin, do you have a preference?

        From Dan Marsden (dan at digitalclay.co.nz) Friday, 1 April 2005, 10:16 AM:

        • sorry, line 149!

        From Martin Dougiamas (martin at moodle.com) Friday, 1 April 2005, 10:29 AM:

        I think it's probably OK if admins can add to choices ...

        From Dan Marsden (dan at digitalclay.co.nz) Friday, 1 April 2005, 11:34 AM:

        fixed.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: