Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-20877

Remove deprecated php function set_magic_quotes_runtime

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Unknown
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      This function needs to be removed as it is deprecated in php 5.3 and will be removed in php 6. It's already being done like this in a few places but Im not sure if that's what we really want to be doing:

      if (PHP_VERSION < 6)

      { set_magic_quotes_runtime($magic_quotes); }

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                andyjdavis Andrew Davis
                Participants:
                Component watchers:
                Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: