Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-20914

Feedback displayed as plain text in IE7/8 in the Grader report with Static students column enabled

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.6
    • Fix Version/s: 1.9.8
    • Component/s: Gradebook
    • Labels:
      None
    • Environment:
      IE8
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      If you enable the "Static students column" feature of the Grader Report, feedback is displayed as plain text during the mouseover operation. If you disable it again, it is displayed correctly. This happens in IE 7 & 8 but not FF 3.5.5.

      I have tested these versions and all have the issue :-

      Moodle 1.9.6 (Build: 20091021) (Bumping for 1.9.6 release)
      Moodle 1.9.6+ (Build: 20091104) (Updated the 19 build version to 20091104)

        Gliffy Diagrams

          Attachments

            Activity

            tlock Tim Lock added a comment -

            Grader - Static students column enabled and disabled in Moodle 1.9.6 (Build: 20091021) (Bumping for 1.9.6 release)

            tlock Tim Lock added a comment -

            Grader - Static students column enabled and disabled in Moodle 1.9.6+ (Build: 20091104) (Updated the 19 build version to 20091104)

            dougiamas Martin Dougiamas added a comment -

            Can you take a look at this?

            andyjdavis Andrew Davis added a comment -

            I'd say a Javascript error is occurring in IE. The contents of the tooltip start out as the title for a div. JS then takes the title and puts it into a panel which is then displayed. That JS is evidently failing under IE so it does the default and displays the div's title in a tooltip. Note that its a default tooltip being displayed and not the fancier looking panel.

            Im setting up a windows VM so I can debug properly in IE.

            andyjdavis Andrew Davis added a comment -

            Tooltips now work in both IE and Firefox. It was caused by an error in the Javascript initializing the page.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Mar/10