Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-20983

Teacher response file(s) not visible to student if no comment is set

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.9.6
    • Fix Version/s: 2.1.3
    • Component/s: Assignment (2.2)
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE

      Description

      Our teachers generally give feedback by using the track changes functionality in word processing packages and add their comments to the original, uploaded assignment, which is then uploaded as a response file. An issue has been noted where no feedback is displayed if no comment is set so the document is not visible to the student.

      Would it be possible to check for the existence of either a comment or a response file?

        Gliffy Diagrams

        1. MDL-20983_for_Moodle21.diff
          0.7 kB
          Henning Bostelmann
        2. MDL-20983.diff
          0.8 kB
          Henning Bostelmann

          Issue Links

            Activity

            bostelm Henning Bostelmann added a comment -

            This problem occurs (in our case) for "Advanced uploading of files" assignments, if the assignment is set to "No grading", and no comments are entered by the teacher, but the teacher sends back response files.

            The cause of the problem seems to be in
            mod/assignment/type/upload/assignment.class.php
            in the "view_feedback()" function, near line 100:

            if ($grade->grade === null and empty($grade->str_feedback)) { /// Nothing to show yet
            return;
            }

            This does not test for response files being present.

            bostelm Henning Bostelmann added a comment -

            Patch for Moodle 1.9 attached

            bostelm Henning Bostelmann added a comment -

            Patch for Moodle 2.1 attached

            bostelm Henning Bostelmann added a comment -

            Resolved in MDL-16553.


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  28/Nov/11