Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-21284

Quiz Results Block not showing IDs properly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.7
    • Fix Version/s: 1.9.8
    • Component/s: Blocks
    • Labels:
      None
    • Environment:
      LAMP
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      When the quiz results is set to show only student IDs, and ID that begins with a 0 is truncated, so that only the 0 is displayed (instead of 023453 for example). The last version of Moodle 1.9.6 would drop the initial 0 and only display the remaining numbers (e.g., 23453 instead of 023453).

        Gliffy Diagrams

          Activity

          poltawski Dan Poltawski added a comment -

          Hi Thomas,

          I can't reproduce the problem in the way that you describe it - 023453 is displayed as 23453 not 0. And the quiz results block ahsn't been updated since 1.9.6 so I do not think the problem with the idnumber is there. Can you check the real user profiles to see if this is the case?

          However I do not think that the idnumber should be converted to a number like it currently is, it should be displayed as a string as this is what teachers will find most useful for using with their student information systems which often care about leading zeros. So I plan to remove this cnversion to nmbers

          poltawski Dan Poltawski added a comment -

          I've applied this change in CVS, thanks


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                25/Mar/10