Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 1.8.12, 1.9.8, 2.0
    • Labels:
      None
    • Environment:
      Moodle 2.0 (20100114) on a Mac Server
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE, MOODLE_20_STABLE
    • Rank:
      26542

      Description

      The LDAP settings window is totally incomplete. It is shown until 'Version' and then nothingelse comes up.

        Activity

        Hide
        Iñaki Arenaza added a comment -

        Hi Ralf,

        have you tested with the lastest (today) version of Moodle 2.0? I fixed something like this yesterday night (European Time) in MDL-21337.

        Saludos,
        Iñaki.

        Show
        Iñaki Arenaza added a comment - Hi Ralf, have you tested with the lastest (today) version of Moodle 2.0? I fixed something like this yesterday night (European Time) in MDL-21337 . Saludos, Iñaki.
        Hide
        Ralf Krause added a comment -

        I updated just before my first message and I updated now again. I get the same broken setting list as before (shown in the screen shot)

        Ralf

        Show
        Ralf Krause added a comment - I updated just before my first message and I updated now again. I get the same broken setting list as before (shown in the screen shot) Ralf
        Hide
        Iñaki Arenaza added a comment -

        Hi again Ralf,

        I missread your bug report. You were talking about LDAP authentication and what I fixed was LDAP enrolment

        I'll fix LDAP auth (and others that are broken aswell) in a few minutes.

        Saludos,
        Iñaki.

        Show
        Iñaki Arenaza added a comment - Hi again Ralf, I missread your bug report. You were talking about LDAP authentication and what I fixed was LDAP enrolment I'll fix LDAP auth (and others that are broken aswell) in a few minutes. Saludos, Iñaki.
        Hide
        Iñaki Arenaza added a comment -

        Fixed in CVS.

        Thanks a lot to Ralf Krause for the bug report!

        Saludos,
        Iñaki.

        Show
        Iñaki Arenaza added a comment - Fixed in CVS. Thanks a lot to Ralf Krause for the bug report! Saludos, Iñaki.
        Hide
        Ralf Krause added a comment -

        I reopen MDL-21343 because I can not see the settings completely again since you corrected the missing string.

        Show
        Ralf Krause added a comment - I reopen MDL-21343 because I can not see the settings completely again since you corrected the missing string.
        Hide
        Iñaki Arenaza added a comment - - edited

        Hi Ralf,

        I know it's hard to belive, but it's just pure coincidence that I corrected the missing strings in auth/ldap and that it stopped displaying the configuration page, but they are not related at all

        There's another bug in the file (present in auth/cass too) related to the output functions used to display drop down lists, that has gone unnoticed for years due to the way params where used in some of those functions. But the new output framework is strictier and it doesn't let the invalid param in, so the display of the page stops with a fatal error.

        I'll commit a fix for auth/ldap and auth/cas (both in HEAD, 1.9 and 1.8) in a few minutes.

        Saludos,
        Iñaki.

        Show
        Iñaki Arenaza added a comment - - edited Hi Ralf, I know it's hard to belive, but it's just pure coincidence that I corrected the missing strings in auth/ldap and that it stopped displaying the configuration page, but they are not related at all There's another bug in the file (present in auth/cass too) related to the output functions used to display drop down lists, that has gone unnoticed for years due to the way params where used in some of those functions. But the new output framework is strictier and it doesn't let the invalid param in, so the display of the page stops with a fatal error. I'll commit a fix for auth/ldap and auth/cas (both in HEAD, 1.9 and 1.8) in a few minutes. Saludos, Iñaki.
        Hide
        Iñaki Arenaza added a comment -

        Fixed in CVS for HEAD, 1.8.x and 1.9.x.

        Thanks lot to Ralf Krause for the bug report and for persevering until we actually fix it

        Saludos,
        Iñaki.

        Show
        Iñaki Arenaza added a comment - Fixed in CVS for HEAD, 1.8.x and 1.9.x. Thanks lot to Ralf Krause for the bug report and for persevering until we actually fix it Saludos, Iñaki.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: