Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-21423

SCORM attempts do not record "first access" or "start time", though that's what Moodle labels them.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.7
    • Fix Version/s: 1.9.9
    • Component/s: SCORM
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      mod/scorm/report.php has a scorm_get_sco_runtime function that selects the x.start.time and lists it as the "Started at" time. However, this does not seem to be the start time for the attempt, but rather the start time for the SCORM session.

      For example: A user starts an attempt on Monday, but they don't complete it. On Tuesday they open the same SCORM, complete it, and submit their work. Moodle will report the start time from when they re-opened the SCORM on Tuesday.

      Perhaps Moodle should/could record firstaccess timestamps for attempts rather than relying on SCORM's x.start.time value.

        Gliffy Diagrams

          Attachments

            Activity

            dougiamas Martin Dougiamas added a comment -

            Dan, any ideas on this one? If not, I can take a look.

            rmeske Ron Meske added a comment -

            I would be happy to provide further explanation of what is currently happening versus what is expected if it would be helpful.

            danmarsden Dan Marsden added a comment -

            haven't got time this week to look at this unfortunately - (kids home for school hols and I'm on partial leave) - happy for someone else to look at this otherwise I'll take a proper look in another couple of weeks.

            thanks!

            valerian valerian added a comment -

            I think this bug is fixed with the patch here : MDL-16184
            already committed by Piers Harding in Moodle CVS

            rmeske Ron Meske added a comment -

            After reviewing the changes in the patch it looks like this does not fix the root issue.

            The issue is that the First Access time should only be set once for each SCO and never updated. Currently it is updated each time the SCO is accessed. The x.start.time for a SCO is used to determine the duration spent in a SCO, therefore it is updated each time a SCO is accessed which is how it should be.

            A field needs to be added for saving the First Access date of each SCO.

            danmarsden Dan Marsden added a comment -

            Hi Ron,

            I've just committed the patches from MDL-16184 - it would be really appreciated if you could test and provide feedback!

            thanks,

            Dan

            rmeske Ron Meske added a comment -

            Please see MDL-16184 for feedback.

            rmeske Ron Meske added a comment -

            Please see MDL-16184 for feedback.


              People

              • Votes:
                6 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  8/Jun/10