Moodle
  1. Moodle
  2. MDL-21481

IE8 can't handle $THEME->sheets = array('styles_changes');

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None
    • Environment:
      moodle20: version = 2010011400
    • Database:
      MySQL
    • URL:
      dwagner.eu
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      13016

      Description

      I made a copy of the theme standardold: standardold2.

      Next I defined standardold as the parent-theme to my theme standardold2.

      I created the file styles-changes: body

      {background-color: green;}

      The config.php looks like this:

      $Theme->name = 'standardold2';
      $THEME->parents = array('standardold');
      $THEME->sheets = array('styles_changes');

      Firefox, Chrome are showing a green background, IE8 does not ?!

        Activity

        Patrick Malley added a comment -

        Hey Dietmar,

        I believe standardold is there for reference during development and therefore should not be used. You should try the same with standard and let me know if you have any trouble.

        Dietmar Wagner added a comment -

        Hi Patrick,

        in the meanwhile I'm only working with base, canvas and standard - without any trouble. Thank you for attending to this issue.

        Patrick Malley added a comment -

        Phew!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: