Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.7
    • Fix Version/s: 2.0
    • Component/s: SCORM
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      I've added some changes to the scorm report, the modified files are attached.

      The modifications includes :
      Complete recoding of the report.php based on mod/quiz/report/overview/report.php, this enable the following features :

      • group select box
      • sortable table
      • collapsable table
      • download in Excel, ODS and text format
      • report preferences : number of elements per page, show scorm details or not, show all students, only attempted or not attempted results
      • tabs navigation to switch between the sco info page and report page. In the scorm/view.php i get rid of the top link "show xxx users"

      Two new files :

      • tabs.php for the tabs
      • reportsettings_form.php for the preference form (based on MDL-18836)

      Solution for this MDL-21421 and an improvement of MDL-16184 :
      The problem is in scorm_get_sco_runtime (locallib.php), because it takes all scoes track ordered by timemodified, and then select the scoes track again but ordered by scoid to take the first one (which is not necessarily the first accessed).
      For me, the changes i've made give more relevant results (the first access is really the first access and the last really the last).
      By using x.start.time, the previous patch takes in facts the last opening of the first sco and not really the first access.

      Sorry but my patch also includes this one : MDL-18835, because it's not included in Moodle 1.9.7

      And sorry for my bad english,

        Gliffy Diagrams

          Attachments

          1. delete_attempt_v2.patch
            2 kB
          2. delete_attempt_v3.patch
            3 kB
          3. delete_attempt.patch
            2 kB
          4. lang_en_utf8.patch
            3 kB
          5. lang_fr_utf8.patch
            4 kB
          6. report.php
            34 kB
          7. report.zip
            13 kB
          8. reportsettings_form.php
            1 kB
          9. scorm_report.patch
            6 kB
          10. tabs.php
            1 kB

            Issue Links

              Activity

              danmarsden Dan Marsden added a comment -

              Thanks Valerian,
              Just a quick note to let you know I've just returned from leave, but will try to have a look at your patches early next week!

              valerian valerian added a comment -

              I'll post a new version of report.php soon because there are some bugs in the present file.

              valerian valerian added a comment -

              ok, all the files needed and up-to-date for this patch are in report.zip

              m91932j MJ added a comment -

              How can i use this patch or how do I add this patch?

              danmarsden Dan Marsden added a comment -
              admssm ivan added a comment -

              Hi,

              Id like to ask, how can i add this report to my moodle..?
              Thank you.

              IB

              danmarsden Dan Marsden added a comment -

              I refactored this a bit and have now pushed to HEAD - thanks for the patch Valerian - it's a much better interface!

              I'd like to backport this to 1.9Stable at some point but it would be good if people could test the version in Head.

              thanks!

              valerian valerian added a comment -

              Hi Dan,

              I find a bug in the delete function : grades are note deleted from general gradebook when you delete one attemp. My patch is attached in the file delete_attempt.patch.

              valerian valerian added a comment -

              Sorry, a mistake in my previous patch. The file delete_attempt_v2.patch is the correct one.

              valerian valerian added a comment -

              Again i'm sorry, please take the delete_attempt_v3.patch for this bug.

              danmarsden Dan Marsden added a comment -

              Thanks for your work on this Valerian! - seems to work fine for me!

              danmarsden Dan Marsden added a comment -

              As Moodle 2.0 is almost out and because this makes significant changes to the UI I've decided to only push this into 2.0 - thanks for the Patch Valerian!


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    24/Nov/10